Unable to edit DNI for Shelly device -

I was just doing some testing with a Shelly 1 which I just added to the hub, the first one since I finally upgraded to the latest release and I went to change the Device Network Id as I normally do and there is no edit button.

And because I am unable to edit the DNI, I keep getting the following log messages and obviously the state does not update correctly.

I have approx. 30 Shelly devices in total and have never had this issue before. Is this a bug in the latest release? or is it due to the "new" add device screen/wizard?

@dcoghlan Hmm, does a reboot of the hub enable the edit flag? Also what browser are you using?

1 Like

I tried with Chrome, Safari and Firefox, all with the same results.

The edit button is available on all the existing Shelly devices that were added before the latest update.

Tried a reboot and that seemed to have done the trick. Not sure whats going on, but this will get real old real quick as I add more and more of these Shelly devices.

Likely just a ui glitch.

1 Like

So I just went through another round of renovations and had to add a whole lot more Shelly devices to the hub and i've been hit with this again. I know that I can reboot the hub, but there is obviously a bug here. I've left it in its broken state so the root cause can be identified. @bobbyD how can I get this looked at? I can't see anywhere to log an official support ticket/bug these days.