Unable to edit a scene -- hangs, even with reboot

I use Groups and Scenes extensively and tried the new Room Lighting. It is insufficient for our needs. So tried to add 2 existing devices to an existing scene. When I do so and press "Done" I get the green spinning circle and nothing happens. Tried to reboot and edit the scene -- same thing -- just hangs.

Any suggestion of what to do?

Deleted the scenes and started the process of recreating them. Had a active log window open when I was doing so. When creating a scene from scratch and adding devices, I press "refresh devices" then "update scene" and it hangs just as the following log entry is written:

Screenshot 2022-10-30 at 3.05.38 PM

What release are you running (Settings / Hub Details) ?

Not seeing any problem creating Scenes on 2.3.3.140. Did you hit Capture in the new Scene after selecting the devices?

What browser are you using?

Platform - 2.3.3.140
Group / Scenes - Version 1.4.1 - 9/26/2022

How do I get to 2.2.3.140? When I click install apps -- I see only 1 option with the word "Scenes" in it. I click it and I am taken to the 1.4.1 option.

Yes - I am capturing the scene.
Browser - Chrome

FWIW, Scene clone fails on every attempt.

Typo.

You have some corruption going on. Download a backup, and then restore it. If that doesn't fix it, use Diagnostic Tool (hub-ip:8081) to Restore Previous Version, and then Check for Updates, and update again to 2.2.3.140.

Thanks for your response.

I downgraded to 2.2.2.141 then upgraded to 2.2.3.140.

Went to previously created scene. Valid, captured, no devices missing. Pressed "refresh devices" and "update scene' for good measure. Pressed Done. Closed appropriately. Reopened and tried to clone it -- just hangs with the green spinning circle. I go back to the Group/Scenes list and see a (null) new scene. I try to both open it or delete it -- and both just hang....

Prior to the platform downgrade/upgrade, I had restored to backups days/weeks back and the problem persists.

Have wholesale deleted the scene and recreated it from scratch and get the same behavior.

Please show a screenshot of this Scene.

(Bruce - I've emailed you the scenes JSON / not sure if you got them.)

I've found a workaround. Seems the issue is due to a device name conflict.

Steps to recreate the issue:

  1. Pick or create a scene with a capture item selected.
  2. Clone it. Can give the cloned scene a name or not as whatever you give it is ignored by the clone process. The scene and devices are named the same as the original scene regardless of what you do -- leave blank or supply a name to the clone process.
  3. Clone it or the newly created scene again. The freeze up occurs here.

The scene being cloned shows up as either (null) or [blank] in the scene list. It can not be edited or deleted at this point.

On a C-5 hub, even a reboot does not allow the errant scene to be edited or deleted. The only way I can get it to go away is restore from a backup. Interestingly, on a C-7 after a reboot, you can delete the errant scene but editing is still not possible.

To work around the issue:

  1. Clone the desired scene with the option to create capture device selected.
  2. Go to the devices created by the clone process. They likely will have a device name identical to the parent scene that was cloned.
  3. Rename the devices to something unique.
  4. For good measure, I also renamed the scene itself to something unique.

After these renames, any number of additional clones can be achieved so long as the devices are renamed after each cloning. Also, any such renamed scenes can be edited. Have done 16 such scene creations via cloning without a problem following the renaming steps.

Thanks for looking into this. We will look further...

Download the Hubitat app