Unable to add actions to Sengled Button

The buttons app stopped working for me once I rolled back to the 2.5 platform which I had to do in order to fix one problem with cloning some of my rules.

Once I upgraded to 2.6 then the buttons app started working again however I am unable to add actions to the buttons due to an error:

The drop-down doesn't display properly but I ticked one of the boxes and clicked Done then the error came up:

I reinstalled the app but had the same outcome again.

I then had another try but instead of selecting the Sengled button I selected the IKEA one at which point the Action options came up and I managed to assign some for testing:

All 3 Actions worked as expected so I am assuming there is an issue with the HE driver (see below) for this button which might have got corrupt after the platform upgrade.

@bobbyD can you guys please investigate this?

I wrote this for a different device, but the same steps should apply to fix yours if this is the problem. My guess is that the numberOfButtons attribute for your Sengled button device is not populated correctly. You can verify this by going to the device page for the Sengled and checking "Current States" towards the top right of the page. You should see "numberOfButtons: 4" (or whatever the correct number is; I think that's right) there.

If not, the following workaround may help you too:

(The Sengled driver itself may have a way to do this--sometimes a Configure or a Save Preferences will do it, but there's no standardized method. The above should work on anything.)

@bertabcd1234 Thanks for the quick response, I appreciate that.

Prior to trying to create an app/actions for the remote, I went to the device's page and made sure it was reporting state when I pressed/held each button which it did then I jumped on the buttons apps however I came across the error I reported.

For some bizarre reason the issue seems to be fixed now. I wonder if it was because I selected the 'IKEA' remote in order for the Action options to display first then I configured the app with test actions? I swear all I got before was that error message.

I checked the device status again and it's now showing the 'numberofbuttons' attribute which I don't remember seeing it there before:
Capture 8

Anyway, I am glad it's working as expected now.


@bertabcd1234 So I've done some testing today and came across some issues:

1 - Buttons 2 and 3 only work properly with the 'pushed' action. What I mean by this is that, for instance if I hold button 2 then it will execute the actions for 'held' AND 'pushed' however for some reason buttons 1 and 4 work as expected with 'doubleTapped', 'pushed' and 'held'.
2- Buttons 2 and 3 won't report state properly, for instance, when I hold it then it reports as 'Pushed' and 'Held' whereas the 'doubleTapped' won't get reported at all which explains the above.

I bought 4 devices and tried 2 already with the same outcome - I wonder if this is something to do with the HE driver or I purchased devices from bad batch.

Here are some screen shots anyway: