Unable to access Dashboard on Mobile App outside home network

I've had the Hubitat mobile app installed for a long time, but never tried to access my hub until a couple days ago. After the app opened, I would click to open the Dashboard but all I would get is a loading screen, after 5 minutes I just closed the app down. I tried it again today with no luck.

The presences feature in the Mobile app seems to be working fine, just can't open the Dashboard.

Using Samsung Galaxy S10+, running Knox version 3.4.1.

Home network is Ubiquiti UniFi, and everything works great when I'm home.
Still kinda new to UniFi, so I don't have any VPNs setup as of yet.

Any suggestion would be great to help me trouble shoot my issues, Thanks.

Not sure if I understood correctly or not, can the app get to your dashboard when your on your home network just not when remote? Worth checking but I'd expect an error quickly if not set, go into apps->dashboards->your dashboard and scroll down to the advanced section and make sure cloud access is turned on. Also scroll up and if you have it set to "Use All Devices" you may want to turn that off and select just the devices in use on that dashboard, it can be a challenge and a pain later down the road to remember to add things there before you can add them to the dashboard but it will speed up the loading once you get it working. Also make sure your hub is on the latest update (at least 2.1.9.117) as 2.1.9.115 had an issue with loosing internet connection and not reestablishing connection (so cloud access wouldn't work) until a reboot. Also try a reboot if nothing else works. Some earlier versions wouldn't reconnect to the internet once it lost connection either until a reboot but they wouldn't generally loose connection too often.

When at home open the app and go to dashboards, at the top there should be a house or a cloud, press it so its showing a cloud, does it work then?

@tterk1
Here what I see at the bottom...

What's under dashboard menu and links

This works.....

This Does Not work.......

Do you have the dashboard enabled for Cloud access?

Open the dashboard app within the Hubitat gui and look for these options.

Also, why do you have so many dashboards? If you swap out one device for another it's going to take you forever to update all of them.

@Ryan780

Still not 100% were to really look to find. Never been this deep in the HE app.

Go to you apps list in the Hubitat GUI by clicking on apps in the left-side menu. Then click on one of the dashboard apps. If is where you have to go to add/remove devices from the dashboard.

image

See, my dashboard "Main" is shown there.

I thought you had to make a dashboard for each room you have devices in?

Could try toggling the remote switch?

Could you router be blocking outbound or inbound traffic?

Where did you get that idea?!? You can make as many or as few dashboards as you want and you can include whatever devices you want.

But can we stick to one issue at a time? Can you find your apps list?

No, that isn't it. The hub establishes a connection with the cloud servers when it starts up. That keeps the connection initiated from the hub, not the cloud.

Its meant to be local so doesn't HAVE to have a external connection??

If you want to use a cloud dashboard it does....which is what the original question is about. It would be kinda silly to try to access a cloud dashboard if your hub wasn't connected to the internet. And if it can't access the cloud, you would get a little notification in the upper right corner of the GUI.

Hence the question could his router be blocking and causing the issue

Do you have

@Ryan780

Clicking on the Dashboard gear.

NO! Click on the name of the dashboard. Click on 2nd floor hallway. Not the gear icon, the actual dashboard.

image

What is outlined in green is how you access the app. How have you been editing any apps on your system if you don't even know how to access them?