UK Postal Code Problem

Trying to register my UK Postal Code in the location area and it keeps telling me it's an invalid postal code and that you only support US/UK/Canada Codes, my post code is a UK post code (I tried a few others non worked), is this a known issue, something new or something that has never worked?

I appreciate you can leave it blank and enter your Lat/Long which I have done, just my OCD kicking in :slight_smile:

Just leave it blank. Surprisingly it also doesn't take Thai postcodes either :smile:. Whatever.

I'm in the UK too and have put my post code in after the long/lat information was put in.
I think I put it in months afterwards just to put it in much like you are saying.
I've used caps as follows.
AA12 3BB

I think they have set it with too many required numbers, mine is currently FY5 1HZ and I managed to get FY5_1HZ in to the system using the underscore in place of the space :slight_smile:

Bump Bump.

Just got my second hub and have this exact problem registering with a postcode in the format of AA1 1AA.

Hi all, is there any fix for this yet?

1 Like

Nope, got my third hub a couple of weeks ago and had the same issue setting it up!

Same here. Still broken

Hello mtate, welcome to Hubitat.

I am not in the UK, but I can sympathize with this not working quite right.

For now, use the workaround above and use your longitude and latitude instead of post code. That will get you up and running.

Sadly, using the underscore did not work, either. Had to scroll with Google maps...:frowning:

Download the Hubitat app