UK. Gas/Electric Smart Meters affecting zigbee performance?

I have started getting zigbee mesh issues after including 3 new devices.
Things would become unresponsive for a period and then get snappy again.
I moved the recently included devices to my spare old C3 to see if the devices were the issue.
Things remained the same on my C7. :thinking:
Then a light bulb moment happened. :bulb:
The issue of my zigbee network also coincided with the installation of gas and electric smart meters.
Scouring the web I found that the smart meters use zigbee to communicate with the 'IHD' which I assume is the 'In House Display' to give updated usage.
It states to try and avoid channels 1, 6 and 11 on you router 2.4ghz band as this can cause wifi interference. The picture shows zigbee channels 15 and 20 shaded so I'm assuming the IHD will use one of these channels.
Guess what channel my troublesome hub is on? You got it, channel 20.
I'm going to allocate a new channel tomorrow to see if this resolves the issue.
I'll give an update but was wondering if anyone else in the UK is having a similar issue with Smart Meters. I've certainly not seen a thread about it anywhere.

1 Like

Not sure on this one but I know they use ZigBee between the devices and there ship, so it would make sense that it is. It's ZigBee green power or something. Think it said its supper long distance of travel. They mesh together aswell so the more people who have them the better when you out in the sticks.

1 Like

Had a look again, yeah they use ZigBee 2.4 for the HAN. Then depending on where you are use the ZigBee smart energy to communicate out to others until they get to one that has a sim that has signal.

1 Like

Before I went to bed last night I moved the IHD into my kitchen on the same floor as the meters but at the opposite end of the house to my hubs. It was sitting on a desk above my hubs.
Last night was the first night for days that things worked 100% through the night.
I'll leave it where it is to see if things have gone back to normal before changing the zigbee channel of my hub. (If I need to).
So far things are looking good. :crossed_fingers:
Tempting fate I know. :grinning:

1 Like

The 2.4 GHz band (also known as the 13 centimeter UHF band) is shared by a lot of different communication devices. It is used by wireless Internet. It is used by some older wireless telephones. It is used by baby monitors. It is used by Bluetooth in your cell phones and Bluetooth speakers and headphones. It is used by some remote controls. It is used by Zigbee devices. Furthermore, advances in WiFi routers have been designed to provide a wider coverage area, which means that you get interference not only from your own router, but also from any neighbors living nearby.

One thing you should do is make sure you have a dual band WiFI router that supports both 2.4 GHz and 5 GHz. Use wired Ethernet connections for all devices you can. Then make sure that you convert all WiFi devices with 5 GHz capability over to the 5 GHz band to minimize interference on 2.4 GHz. Also make sure that you are disabling Bluetooth devices that are not used routinely.

Finally, try to make sure your WiFi router and Zigbee networks are on different frequencies. The three WiFI non-overlapping channels 1, 6, and 11 use the same frequencies as Zigbee channels 11-22. I have read that Zigbee channel 26 is minimally affected by WiFi, however, many Zigbee devices do not support this channel. Try to avoid using Channel 11 on your WiFI router if at all possible as this is going to be the one that will interfere most with your Zigbee network.

There are apps for your Android phone or iPhone that will help you deterimine which WiFI Channels are in use on your network.

Although of lesser consequence in residential neighborhoods, some industrial, scientific, and medical devices use the 2.4 GHz band. Even microwave oven emit frequencies in this range. Sirus XM satellite radio also broadcasts in this band.

Amateur radio operators (Hams) are allowed to use the 2.4 GHz (13 cm) band as well. There frequency allocation may interfere with WiFi channels 1-6.

The condensed version of all this is: the 2.4 GHz band can be a mess.

1 Like

That may all be true, but this thread is about the problem OP is experiencing that’s probably been caused by the electric utility provider’s zigbee devices.


I agree that the problem MIGHT be due to the electric utility adding some Zigbee devices. However, there are many other possibilities as well. Problems are always the result of something changing, but there could be changes that the OP is not aware of that could be the cause of his issue. For example, a neighbor might have gotten a new WiFi router that is using the same frequencies. Or a neighbor might have added a Hubitat hub and Zigbee devices. The possibilities are numerous.

I do not know the rules of consumer devices in the UK, but I know that in the USA, industrial devices such as a power utility device take precedence over consumer devices. Consumer devices are not allowed to interfere with scientific, industrial and medical (SIM) devices and they must accept any interference caused by such devices.

The UK has its version of the FCC and part 15, I’m sure.

1 Like

This has not changed but you are right that it needs to be considered.

This one is most definitely a no. :slight_smile:

My testing and 'fiddling' :wink: leads me to be 95% sure it was the introduction of the new 'Smart' meters interfering with ch20. The hub using ch20 has the majority of my zigbee devices paired to it. Moving them to my C3 running ch15, all of the automations, albeit a small number, have no issues.
Since I moved and subsequently turned off the IHD (I would hardly ever use it anyway) things seem to have settled down. :+1:
I will give it a few more days to see what happens but if I still get issues I will change the zigbee channel on my C7 that holds my zigbee devices. It doesn't actually take too long for me to go round and re-pair my zigbee devices apart from 2 which are in my loft space.
Here's hoping.

BTW thank you again for responding as I believe it is always good to get ideas from other people.

EDIT: I also plugged in a spare zigbee outlet and using Hub Watchdog, I'm monitoring the device for zigbee delay times.
This is how things have been running for the last 4 hours.
Top readings are from a virtual switch.
Bottom readings are my zigbee outlet. Doesn't look too bad at the moment. :crossed_fingers:


1 Like

I'm still battling, I got sky q few weeks ago and it's playing havoc because of the wifi mesh it has, it keeps hopping channels and there is no option to lock them.
Trid moving zigbee channel to the highest as it seemed safest but the ST presence sensors don't work!

I basically have 3 wifi routers constantly changing and blocking out the intire zigbee range!

Do you really need three WiFI routers? Unless you have a 6000 sq ft mansion, one WiFi6 (AX) router might be sufficient. As you say, if you have three WiFi routers one is going to claim channel 1, one is going to claim channel 6 and one is going to claim channel 11, effectively overpowering the Zigbee devices.

Even if you keep all three routers, you might be able to disable the 2.4 GHz radio on at least one of them. If any of your devices can be connected using Ethernet cables, do so. If any of your devices have 5 GHz radios, be sure they are connected at 5 GHz. Only use 2.4 GHz WiFi for those devices that do not have any other way to connect.

I like using a combination of 2.4 GHz WiFi, 5 GHz WiFi, Zigbee, Lutron Clear Connect, and Z-wave devices to cover a variety of frequencies. That minimizes the traffic on any given frequency.

1 Like

Nope but sky q makes a mesh, I have two boxes and and router and there no way to turn them off or lock the channel

Not trying to hijack this thread, but can HE communicate with a Zigbee electric meter? Mine (here in the US) is also Zigbee and I have a Raintree meter in my house showing me my power usage.

You should be able to turn it off if you don't need it?

I've got CAT5 throughout here so always prefer Ethernet where possible, plus a multi-AP WiFi system that covers the whole property / gardens / outbuildings. I don't want / need any other WiFi.

When we I had Sky Q installed a couple of years ago they insisted it had to be setup as per their document with their router / hub only and the WiFi mesh to connect the boxes. They refused to even consider setting it up hardwired.

The "engineer" had barely reversed off the drive before I'd disabled their WiFi, plugged their boxes into the CAT5 ports, removed their router / hub and switched back to my Draytek Vigor. All works fine needless to say, so no idea why they were so hellbent on setting it up that way.

1 Like

The reason I prefer z-wave over zigbee

I'm wondering why utility companies use the super jammed 2.4GHz for a wide network mesh, and they even asked the customer to avoid 1, 6 and 11 wifi channels which I would say too much to ask and stupid. Any channel in between will overlap with one of the 3 channels anyway, pretty much asking the customers not to use 2.4GHz wifi.

The utility companies altogether should be able to afford and ask authorities to use a separate band rather than causing interferences to customers devices.

How do you turn the WiFi off on the Q box's there's no option to disable 2.4

Should be in the Installer menu. But you'll need to connect the Sky Q boxes by Ethernet first otherwise they won't work.

There's a guide at whch shows the process. Basically connect each box by Ethernet, reset the network on each Sky Q box so it detects the Ethernet connections, then turn off the WiFi in the Installer menu.

Ta, I didn't know about the hidden menu. I've turned 2.4 of on both boxes hopefully that will reduce the interface.
Any idea how to fix the channel on their latest router?

Not sure about that as I never used it. But for 5G you'll probably be OK leaving it, especially if you're still using the mesh aspect to connect the Sky Q boxes.

I believe it used channels 35 of 5g preferred. I did some work on a house the other day with issues and there is a hidden menu that allows you to turn off the 2.4 or 5 band. In that case I disabled the 2.4 to reduce noise. The master box was connected over Ethernet then that allowed the 2nd box to be connected to that over 5ghz only.