Two Zigbee Sengled Bulbs Will no Longer Pair after C8 Migration

Sengled soft white ZigBee Candelabra base bulbs. Model EIF-N9G.

These two bulbs were connected fine for about six months on my C7 hub. Then they migrated just fine to the C8 and they were working for about a week or so up until...

I bought another MHCOZY Zigbee Relay board, to add to the two I already had connected and which had migrated to the C8. I had issues with it not initializing, which led me down a rabbit hole of changing things, such as the ZigBee channel. That did not help, but I finally found the rebuild network button on the ZigBee page and that got the relay board working.

Meanwhile, while messing with the ZigBee network for that, I lost the two Sengled bulbs from the network. I could not reconnect them and get them to initialize, but I did finally managed to get them connected by using rebuild network again. The problem is they do not STAY connected now. They only work for about 10 minutes or so. I changed the ZigBee channel back to what it was before, but that did not help the issue. I factory reset them each time I try to pair again.

One thing to note: Looking at the device graph, these now always have a light-gray (tentative) line connecting to the hub. This also causes them to keep coming up as "reconnected" when running ZigBee pairing, they claim to reconnect every time I run it, but they usually will not work after. Sometimes it will say it reconnected while the bulb is still working fine, and then it continues to work, until it doesn't later. The bulbs never seem to "fully" pair now no matter what I do, though they were paired fine before from migration.

I've deleted the devices and started over many times. I get the bulbs tentatively connected then they drop off a short time later. It would appear that the hub is "remembering" something that does not allow them to re-pair correctly. I still have two other of these brand bulbs on the network and they are working fine, survived upgrade and me messing with the ZigBee channel. It is just these two that now off the hub, they do not want to go back.

I have plenty of repeaters (other bulbs and outlets) so that is not the issue. I also tried pairing close to the hub and away from the hub, but the graph seems to show they always pair to the hub tentatively and then find new connections after through the repeater devices.

Another Note: To confirm the ZigBee relay board was actually good, I fired up the old C7 and proved the board could connect to the old hub. Since it had been awhile, I assumed that there would not be conflicts with the hubs since ZigBee devices had been on a new hub for a bit and they wouldn't connect anyway. I also tried this with the bulbs, they would pair fine to the C7 still, just not the C8. I mention this because they were paired back to the C7 for a short time before going back to the C8. Are the bulbs holding on to something like a hub ID? I am not sure what a bulb device stores for connection data, but I would think this would be cleared with a factory reset.

The bulbs are on sale now two for $14 on Amazon, so I am going to just try two new bulbs that have never been connected to the hub. Still, it would be nice to know if there is a solution to this issue and what exactly is going on.

What are these other bulbs (brand and model)? How many? Are you sure they aren't the problem? If you can, does disconnecting them fix the problem?

Many smart bulbs are known to be poor repeaters, "eating" messages instead of passing them along to other devices like they are supposed to -- mostly early ZLL and ZHA 1.2 bulbs, but I don't know of anyone having objectively tested anything more recent (just anecdotally, people seem to not have problems).

The bulbs do store data on the network they are joined to (I don't recall if it's just the PAN ID, the extend PAN ID/IEEE address, or both), but you are correct that a reset of the node should clear this, so that is unlikely to be a problem -- especially if you got the device to pair at all.

The other bulbs are also Sengled soft white, but with a regular lamp base. In the Living Room there are two of these candelabra base that are still working, surrounded by the three other Sengled bulbs in lamps. All these are all working fine. The two that stopped working are back in the bedroom, both used in bedside table lamps. They are the only bulbs on that end of the house, and the the hub is in the hallway between the bedroom and living room.

I can see on the graph that the other bulbs act as repeaters, but I read that the candelabra based bulbs do not. I also tried pairing the problem bulbs in the living room and leaving them there, but they do the same thing where they do not stay connected.

do you have the other hub (C7)shutoff?
do a Zigbee "scan channels" under Zigbee details, do you see an unknown network duplicate on any of your channels?

This is my C4 hub, I have no idea what it means and no one has explained how this is possible, unless it's a glitch in the network scan logic, and my Zigbee isn't great

Yes, the C7 hub was immediately shut down after the testing with it.

Things must have changed since the C4 hub, I have no "scan channels" option on the ZigBee details page. I have no duplicates in the list that shows by default in ZigBee details.

The new bulbs arrive Saturday. I will post if they pair OK. It really seems like the other two bulbs and the hub will never be happy together again. If the new bulbs pair, the hub must be hanging on to something about the old bulbs in a Zigbee table somewhere, or something, that is causing the issues.

'Scan channels' still shows up on the C-3 (as of recent beta); it shows up in the details page here:

Note that C-3, C-7, and C-8 each have their own spin on 'Scan channels' output is displayed:

C-3 will display all detected PANs, hoever (like the C-7) extended PAN ID's display in reversed byte & nibble order. For example if Zigbee details page show the hub's extended PAN ID is 12345678912345678, it will show up on the 'Scan channels' page as 87654321987654321

C-7 displays all detected PANs except its own (so the entry for its own operating channel appears blank; if it's the only PAN in your vicinity, there won't be any info on the page)

C-8 displays everything as you would expect.

I guess I missed the scan channels button looking for it last time.

Every channel shows 0/blank except 20, which I am using.

20 -66 136 80AD 04E93B986D18B73C

Update: I got the two new bulbs today (early).

These two brand new bulbs will not connect to the C8. They are doing exactly what the old bulbs were doing - issues initializing, then once finally initialized they work for less than 10 minutes. Running ZigBee pairing always finds them again as a device that was previously connected (though nothing indicates that they were no longer connected). Then they do not work when "reconnected". They also did not connect out of the box (as they should have, as the did originally, they blinked when plugging them in to show they were ready to pair) and I had to reset them again to even get them to initialize.

At this point it is fair to say this is totally a Hubitat C8 issue since new bulbs never on the Hub are doing the same thing.

These bulbs pair fine to the C7. They migrate fine from the C7 to the C8. The C8 will not connect a bulb from scratch (that lasts) unless it has been migrated from a C7.

I now know that if the two migrated bulbs that are still working ever get disconnected, I can basically throw them out since they will never be accepted by the C8 again. Bummer.

Can someone fix this or would it be low priority?

I may have missed it, but did you try any of the following?

  • Changing Zigbee power level
  • Switching to a different channel
  • Trying to pair with option to exchange key in the clear
  • Trying the option to pair avoiding Zigbee 3.0 repeaters

For me, I tried a multitude of things to get this one device to pair. It kept bombing out like your devices. I was on channel 20. I switched to channel 25, and was immediately able to pair the device successfully.

The one difference is this was a new (not previously paired/migrated) device.

Others have said the 3.0 repeaters have created pairing issues.

Yes, I tried changing channels. The two connected bulbs worked on that channel as well, but the two that I was trying to rejoin had the same issues. I went back to the original channel after. I did also try changing power levels.

Yes, I tried every option for pairing, what finally worked to get Hubitat to at least think it initialized them was the rebuild network option. It just does not last.

I left the two new bulbs sitting yesterday and checked on them occasionally. At different times, one or the other was working without any intervention by me. Later on, it would be swapped, the other one worked now and the other did not, or neither worked, or sometimes both would work.

Looks like they get a bad route somehow when they connect through different devices and then get a good route and they work again. Why the working migrated bulbs do not do this is a mystery.

The original driver I used was just the Generic Zigbee bulb. The two working bulbs are still using this driver. I have found that many drivers work, including the built-in Sengled Element legacy driver. Generic Zigbee dimmer also works. I do not think driver is the issue here, due to the migrated bulbs still connected fine on the C8 with the generic driver.

Device logs do not show much, just that they get a configure... and and refresh() called... each time they reconnect. I see them doing this on their own without me even running ZigBee pairing, though running pairing will log this as well when they connect. Even when they "connect" this way, they usually do not start working. It is more like they are always just trying to connect.

I did notice that the new bulbs are missing In and Out Clusters in the device data. Looks like that is a symptom of the underlying problem and it explains why they are not "really" connected.

Here is the device Data for one of the bulbs with issues:

  • endpointId: 01
  • application: 22
  • firmwareMT: 1160-8077-00000022
  • manufacturer: sengled
  • model: E1F-N9G
  • softwareBuild: 00000022

Here is device Data for one of the still working Migrated bulbs:

  • endpointId: 01
  • application: 22
  • firmwareMT: 1160-8077-00000022
  • inClusters: 0000,0003,0004,0005,0006,0008,0702,0B05,FC11,FC57
  • manufacturer: sengled
  • model: E1F-N9G
  • outClusters: 0003,0019
  • softwareBuild: 00000022

This scenario (mainstream Zigbee devices working fine on older hubs which fail to join or stay connected to C-8) has existed since the C-8 came out with no progress on fixing it... either it's not known to the HE developers (not likely), unfixable, or not worth prioritizing over other efforts.

Since 2018 I can't recall many reports of mainstream Zigbee devices which worked fine on one vintage hub yet wouldn't join at all to a newer one, until the C-8. Being on the "List of Compatible Devices" in HE's documentation isn't relevant. The issue always seems to involve end devices, not routers; pretty sure your Sengleds fall into this category.

Evidently most users have no issues with end devices on C-8, but it's unclear if those were migrated vs. newly joined (or reset/rejoined) devices: those which need to request the network key from the Trust Center in the hub.

This could be relevant; AFAIK the migration process transfers the network key from C-7 to C-8, meaning migrated devices continue to use their 'old' network key (as opposed to newly joined or reset devices which need to request the network key from the hub-- which is itself encrypted by the 'well known' link key during the transfer).

Security key handling (aside from multiple profile support) is the only real differentiator of C-8's Zigbee 3.0 ; according to PR of the Connectivity Alliance it should be possible to accommodate the key exchange methods of legacy devices with a Zigbee 3.0 coordinator, but it's obviously not trivial.

With the C-8 it appears that the network key exchange process doesn't always work, and the alternative join options don't fix the problem. Results seem to vary depending on whether the network key request is issued from a child device of a router, or from a child device of the hub itself... maybe another variable making this a tough nut to crack.

So much for join difficulty issues... as yet unexplained is why successful joins of these devices still disconnect, another not uncommon C-8 Zigbee complaint. With an unproven mesh this might be explained by signal blockage or range issues, but we're talking an established mesh here. What's interesting in your scenario is you have noticed that left alone, newly joined but subsequently disconnected devices will spontaneously reconnect.. for a short time. That's a wrinkle I don't recall seeing before. That's what properly joined Zigbee devices should do (except the disconnect part).

At any rate, there may be nothing you can do to get around this, other than do what others have done: move the problematic Zigbee devices back to the C-7 and use hub mesh if you still want to use the C-8 to control them.


Thanks Tony for the explanation. I gave up on the bulbs and I am just using a ZWave dimmer outlet to control both of them now. They don't really need to be independent bulbs.

I thought about using the C7 with hub mesh, but not worth it for just two bulbs. On a side note, I had an old ZigBee motion/temp sensor that stopped reporting yesterday, as it has a tendency to do, even with the C7. My go-to to fix has been to just reset it and let it rejoin - but I forgot about the C8 migration issue before I did that. It took me many many tries to get the sensor reconnected (it wouldn't initialize, typical of this issue). I was surprised when it finally did reconnect. I had to delete the device and create a new one, and rebuild network to finally get it reconnected. It is still working 24 hours later, so I think that one is good.

So it is worth it to keep trying, up to a point. The fact that the brand new Sengled bulbs would not fully connect either makes me wonder. I don't think these specific bulbs will pair for anyone on a C8, unless they are migrated them from a C7, unless something in my network just doesn't like those bulbs at all anymore simply because some of them were migrated at one point from the C7.

I would like to know if anyone can get these working from scratch on a C8, but I'm pretty much over it now and moving on.

1 Like

I've definitely been struggling with these bulbs as well. I can confirm pretty much everything you've said above. They migrated from my c5 and worked perfectly for months. I had an extended power outage that broken both zigbee and z-wave networks, but in weird ways. Most of my sengled bulbs dropped off the network and wouldn't rejoin or would get stuck halfway. Tried changing power, channels, repeaters, new bulbs etc. I got a few back on the network but some have dropped off again, one did rejoin on its own spontaneously. I've been fighting this for about 6 months now and have tried repairing or adding new well over a hundred times now. Devs either don't care or can't fix whatever is broken with these from what I can tell as it seems to be a common issue with the C8.
I have about 15 bulbs in use and 5 of them have been none operable and unscrewed for the past 6 months, so I'm not ready to give up at this point. I don't want to reconnect the c5 just to run these as splitting the network would cause issues with repeaters and whatnot. I also have limited available spectrum in the 2.4 Ghz band and going up to channel 25 interferes with the remote start on my wife's car somehow (whole other story). I also have 10 other sengled bulbs not in use at the moment as I have replaced them with wled bulbs for live holiday animation. Needless to say, I'm heavily invested in these bulbs for their color, brightness and reliability (at least with the c5), much more money than what the habitat costs, so it definitely makes me question the best path forward.
Just wanted to share that I feel your pain and hope that hopefully something will be done to remedy this at some point. I had one of my most used bulbs drop a couple days ago, so I'm on the search for a solution again and it's sad to see that no real progress has been made. It appears to be radio silence as usual, still.

It is hard to just give up. I re-paired them in my basement the other day (far away from the bedroom) and they paired quickly and stayed working for hours. Watching the device graph, it looked they paired through a repeater this time at initialization instead of directly to the hub, and maybe that was it.

After they worked for awhile I brought them back to the bedroom - back to their old behavior. I noticed they were skipping my repeater outlets in the hall, and reaching out to the other Sengled bulbs in the living room far away!

I have added a plug outlet in the bedroom right next to them, and they still didn't want to go through it, even over time. They just get routes that do not work, then things change and they get a good route.

It kills me that they migrate and work but do not pair and work, but I am not as heavily invested in these as you are. I just bought 4 Sengled E26 base that match the ones I have that do repeat and seem OK with the C-8 since as they are a deal right now at about $5 each if you buy four on Amazon. I bought some e11 to e26 adapters for those candelabra lamps to use these instead, since Sengled seems to have the market cornered on candelabra base Zigbee bulbs and I could not find other options.