Tuya Zigbee 3.0 CCT light controller not reacting to color temperature change

Just purchased this controller which is actually re-branded as a MiBoxer 2-in-1 LED Controller. I added the device as Generic Zigbee RGBW Light - which has worked for my Gledopto controllers. The device/driver combo works mostly fine but there is one problem: I cannot change the color temperature. I tried with only warm-white and only cold-white wires in the controller and the corresponding LEDs illuminated as expected. I also tried another LED strip with the same results. Now, with both warn&cold white wires attached, both LEDs are illuminated but there is no effect when trying to change the temperature.

The device details for the data section reads:

  • endpointId: 01
  • application: 40
  • inClusters: 0003,0004,0005,0006,1000,0008,0300,EF00,0000
  • manufacturer: _TZB210_lmqquxus
  • model: TS0502B
  • outClusters: 0019,000A
  • softwareBuild:

and the logs for this device:

Since the setup mostly works, I could imagine that it might be possible to get the temperature adjustment working too. Does anyone have any ideas on how to fix this? :smile:

PS. Another thing that is not working 100% is the level up/down action; the light goes up/down a bit but not all the way to min/max - but this is a smaller problem for me.

Device's product page: https://miboxer.com/product/2-in-1-led-controller-zigbee-3-0-2-4g

EDIT: I just moved this device to my Samsung SmartThings Hub and although it recognized it as a light, the temperature adjustment does not work there either.

First off, see this post

Then manually change the driver to "advanced zigbee rgbw", save device, then without removing or resetting the device initiate pairing again, after changing the driver

@Rxich Thanks for the quick response. I added the device from scratch, changed the device type to "Advanced Zigbee RGBW", saved, then set it to pairing mode from the device, re-added - but it still did not work. BUT when I went to check if I had all the wires correctly, I noticed this at the top of the device:

There was nothing said in the instructions on how to use this feature but after some trials, a double-click switched the mode, and the indicator LED turned green. Now the color temperature works with the "Advanced Zigbee RGBW" driver but also with the "Generic Zigbee RGBW" driver.

So, for now, everything seems to be working. Thanks!

1 Like

Excellent, glad you were able to get it working. Let me know if it doesn't behave on the Zigbee mesh, aka falling off or causing lags in the network