Tuya motion sensor driver

Anyone found a solution to get the new devices to work?
My manufacturer is: _tz3000_msl6wxk9
And I have the same problem, device connects but doesn't work.
battery @ 3.11v, checked the connectors and tried 2 different sensors.
The konke just doesn't seem to work on these.

Hope you had this sorted out.
I have got couple of this which they all looked the same but manufacturer are different. I don't know why but I got them to work by re-pairing the device a few times. Switching between the generic Zigbee motion driver and the Konke a few times... and then it works....
why ?? I don't know...

I tried that multiple times, but didn't work (yet). You do give me hope tough, they're not in the bin yet so I'll give it another try!

Does your PIR sensor look like this?
image

no, it are these:

I tried at least 10 times to connect, remove, reconnect and change between Konke and generic zigbee driver but it just doesn't work.
Don't buy them, they don't work any more.

The Sonoff's are cheap too and work reasonably well for the price.

That's the bad thing with all Tuya devices - the manufacturers may change the firmware / the comm. protocol without even letting the resellers know about the change, and they continue selling it as if it was the old product...

I agree Sonoff is much more stable and safer to buy (despite looking a bit uglier...). I am using two Sonoff motion sensors for about a year now without any problems.

@sirkitealot before you put these things back into the junk drawer, can you send me in a PM some logs with Debug option turned on (use any driver that shows some activity )? Remove and re-insert the cell battery at least once during the tests.

I have been using the generic no temp with ones I bought a couple weeks ago. It took a lot of fiddling to get them to work, but they do work, mine says they are _TZ3000_msl6wxk9. I had to start with generic motion, configure, refresh and then switch to generic no temp and all 6 of mine work. Unfortunately, they do get hung on "active" in Hubitat from time to time and require a push of their button but...not sure why that happens. Konke driver would not work at all.

I've just got mine going using Linkind motion sensor, shows active and inactive and takes around 1 1/2 minutes to reset to inactive

Tnx for all your input, I'll report back when I've tried your options!

Yeah, I am not a huge fan of these. I have one that gets stuck on active (twice so far this week) and I need to press the button on it to get it unstuck, after hours of the controlled light being on. Feeling I should have spent more money on a better quality sensor....

Well, now I have to really change my opinion on these. I played around a lot with these after reading recommendations for other objects and found that pairing them, removing the battery for a minute, putting the battery back in and pairing them again (without removing them) helped a lot and was even able to load up the Konke driver, which made a huge difference for how they behave and they don't get stuck on "active" anymore. I hope this helps others out.

1 Like

I use these with the konke Zigbee driver and they work perfectly. Documented elsewhere in the forum. I love these little sensors. Mine reset in 15 seconds which is so cool. I hope Tuya didn’t mess them up.

1 Like

Finally found some time to try again, not giving up :wink:

  • "I had to start with generic motion, configure, refresh and then switch to generic no temp": tried that, didn't work.
  • "using Linkind motion sensor": tried that, didn't work.
  • "removing the battery for a minute, putting the battery back in and pairing them again (without removing them)": that actually does something, it gives batt status 100%. But still not working.

Please post both the Model and the Manufacturer values from the device Data section. There are many variations of these motion sensors, although they may look the same.

I have also found. that some of these TS0202 motion sensors do not work (can not even pair) if your HE hub zigbee channel is not one of the 'standard' 15-20-25 channels.

You can check which Zigbee channel is used from the Settings->Zigbee Details page.

  • model: TS0202
  • manufacturer: _TZ3000_msl6wxk9
  • zigbee channel: 0x14 (20)
    I tried changing it to channel 15 but didn't work either. So I set it back to 20 because all other devices didn't work any more on 15.

Can you try this driver then? The driver is intended to handle the much more complex 4-in-1 motion sensors and is maybe overkill for this simple motion sensor... but maybe not?

Please first change to the linked driver, then REMOVE the device from its web page, then remove the batter for few minutes and pair it again to HE. The driver should be automatically selected. If it still doesn't work, we can handle it in there.

1 Like

Hail to the hero @kkossev he fixed it!
It works with the updated driver! It auto-selected it the first time. Also it sends the "no motion detected" signal so is has full functionality, contrary to what others say.

Topic solved! (at least for me)

1 Like

Download the Hubitat app