Troubleshooting zigbee bulb responsiveness

I have one single device that I seem to continually struggle to control and/or refresh. It's a Sengled RGBW Bulb. I have 2 of these bulbs, one in each of my garage sconces. The right side bulb is fine, never had a problem. The left side bulb is hit or miss. It usually works ok, I'd say 75% of the time. Sometimes though it responds to commands but the device page never updates status, and sometimes it doesn't respond to commands at all.

I'm on Zigbee channel 20. No interference with other wifi channels, closest one that shows in my Wifi Analyzer app is channel 9. HE hub is sitting right next to my wifi router, which is on channel 7. I have 6 Iris Zigbee plugs scattered throughout my house. The hub is about 30 feet from the bulb, and the closest Iris plug is about the same in a different direction.

From Zigbee Logs, the RSSI and LQI seem ok from my limited knowledge. I think I read somewhere that the closer the RSSI is to zero the better. None of my devices are higher than -50 though, even a contact sensor that's 2 feet from the hub. Not sure if this is normal.

I can try to get another repeater and put it in the garage, closesnt outlet is probably 15-20 feet from the problem bulb. But with good RSSI and LQI number I'm not sure if that would help. So...anyone have suggestions on what to do next?

It sounds like commands are mostly getting to the bulb, but the bulb's radio is having a hard time sending data back.

To determine if it is a signal strength/interference issue, try swapping the two bulbs. If the problem follows the bulb, you may have a flaky bulb. If the problem follows the location, I would guess you need another repeater to boost the signal strength.

1 Like

Here's a diagram. Black dot is the hub, blue dots are repeaters, green dot is the bulb that works fine, red dot is the problem bulb.

Now that I see this mapped out I think it could be a distance issue. I'm confused on how I could be seeing good numbers in the logs but still having control problems though.

Agreed. It looks like the red dot light just needs a repeater in the garage to help improve the signal. I'm not a zigbee expert, so I don't exactly know how to interpret the RSSI/LQI values, or how useful they are in practice. I seem to recall some comments that those values are for the last hop, whatever that means... :wink:

1 Like

Thanks for the input. Funny how obvious this looks when I actually map it out...I was pretty sure I had enough repeaters but it's clear that I don't.

I'll go grab another Iris plug today. They are getting harder to find around here....the 4 Lowe's stores closest to me are all out.

A follow-on question to this...when I add another repeater in the garage, will the bulb pick it up automatically, or will I need to kick off a "panic mode" heal process? A prior post from @JDRoberts seems to imply that I would need a heal in order for it to pick up and use the new route, but @bobbyD posted in another thread that zigbee was self-healing and it wasn't necessary. Thoughts on this scenario, adding a new repeater to an existing mesh?

I think I’d turn off the hub for fifteen minutes after joining the new repeater. That way you’ll be sure that the mesh rebuilds.

1 Like

New repeater added at purple dot. Hopefully this does the trick. Time to induce panic :sunglasses:

Left bulb did not update state again yesterday after it was commanded on. It did respond to the command but I had to manually refresh it later to get it to update. I'm thinking there may be something wrong with the bulb. If it happens again I'll probably order another one and see if that fixes it.

Did you swap the bulb with the other one?

I had a very similar situation, but after adding the repeater I had to reset the bulb then repair(without deleting it from HE) so it will pair using the nearest repeater. Like a Xiaomi thing......

Garage doors cause impact to the bulbs signals, my bulb worked fine with the door open. That could be an option, you are very good doing rules, make a rule garage door open before X rule runs then close :joy:

I didn't swap them but I did shut off the zigbee radio in the hub for 20 minutes in an attempt to force a mesh rebuild. That should have made the bulb search for the new repeater, right? I can try to reset if necessary but I was thinking I already took care of that part in a different manner.

My neighbors probably think I'm nuts already, I go outside and stand in the driveway playing with my phone to make the lights change colors, and last night I was testing some changes to my garage door controller using power reporting from the new outlet to tell if the door is moving instead of an acceleration sensor. Door open, close, open, close, open, close, etc....I ran it so many times the thermal overload kicked in :rofl::rofl:

Oh wow!

Honestly I suggest resetting the bulb, maybe it's not self healing like the way everyone said, and I said because Xiaomi doesn't, so who knows, maybe Sengled implemented zigbee in a special way, it's 5 minutes to do the exclude and repair.

1 Like

Couldn't hurt I guess....will give it a shot. Thanks :slight_smile:

1 Like

Reset and pair complete. That was easy. Fingers crossed...


Oh boy now the right light isn't refreshing :rofl: Time to reset that one too.

Left bulb didn't update status again after turning on at sunset. Set up a rule to refresh both bulbs 5 minutes after the primary scheduled rule changes truth.


I'm assuming this is a problem with the bulbs themselves, can't imagine at this point that I have a mesh problem. No issues with any other zigbee devices besides these bulbs.

With a rssi of -54 I don't think it's a mesh problem, maybe 2 Yeelight works better.

1 Like

Knock on wood...I haven't had any issues in 5 days. Both bulbs have logged on and off events at the correct time. Maybe the mesh finally figured out the repeater was there. :crossed_fingers:

Update: Still having problems with one of these bulbs. I've had to reset one of them a few times after it's become unresponsive to commands. Reset and rejoin and it's fine again for awhile. No idea what the problem is.

Just reset them both again and swapped positions to try and see if it's a bulb problem or a location problem.