Trouble with GE Smart Fan Control (12730) and Google Home

I am having a problem with my GE 12730 Smart Fan Control. It is paired with my HE just fine and works as intended. It is showing as GE Smart Fan Control Type.

The problem I am having is that Google Home is showing it as a light. I have two switches (Office Lights) and (Office Fan). The other switch is a Zooz dimmer. Whenever I tell Google to turn on or off the Fan, it works correctly. However, if I tell Google to turn off or on the Office Lights, both the lights AND the fan turns on or off.

ST handled this correctly. I am at a loss to what else to try.

Any suggestions?

This is a problem with Google not HE. All dimmers show up as lights by default and they can't be changed. I put all my fans into a separate room in GH called Fans. That way, they are controlled independently of the lights in a room.


That seemed to do the trick. Thanks.

1 Like

Google Home is off it's rocker right now.
I'm noticing some weird things.
Hopefully it's temporary.

This link has done decent theories:

1 Like

Actually, it's not Google. Our HE guys opted to only implement fans as dimmers. There is an actual fan type that they opted not to use.

For them to use the fan control in Actions on Google it would have required sort of a paradigm shift on our part though. The fact is we are used to saying set the fan to 50% or whatever instead of set the fan to medium.

I modified this driver to work with hubitat enough to save and be selected in the device settings. (It only took changing from physicalgraph to hubitat in the package names.)

Even with a device driver that doesn't implement any light capabilities it seems that HE forces it to a light if it implements switch control. For now I will use your workaround of putting the fan in a different room but I don't like it. Google's speaker/display devices are room aware (they know where you put them as you implied above) and if they do more along the lines of requiring you to use the room name to control devices outside the room it will be annoying later to control fans if they are in a different room.

Also, it would be nice to just say "turn on the fan" in any room with a fan and a Google device. I love being able to just say "turn on the lights" in any room with a Google device and have it only turn on the lights in that room.

Yes, unfortunately the Google Home/Assistant support in HE is very lacking compared to ST and a few other solutions.

While it doesn't sound like they have any sort term plans to improve it, I hope they reconsider that stance. But I do appreciate that there were limited resources and a lot to work on.

The situation is similar in Alexa, too.

I'm only a couple days into HE, but my issue with the GE fan controller is different. It loads and shows up in HE as a GE smart control fan. In Google home, it transferred as an on/off switch only. The google Home app doesn't give me any speed control options, and if I speak a command other than on/off it says not sure how to help. With smartthings, google home would pass through the speed request as a numerical value, ie. 30 percent. You couldn't use Low, Med, or High without work arounds.

Any inputs on why my switch is seen as a simple on/off switch rather than dimmer in Google? Also, are building virtual switches the best option folks have found for controlling their fans using Google Home, or are there better options with rules which I'm still very unfamiliar with?

I believe I had this issue when I added one of my GE Fan controllers. I had to actually factory reset the switch and re-pair the device before GH would correctly identify the device.

Also apparently in the 2.0.9 update fan controllers should be identified in HE correctly and not as a dimmer, so this in theory should allow GH to see the device as a fan instead of a light.

As an update to my issue here, I reset, deleted out of HE and Google home, always the same in that HE showed the switch as a dimmer, Google home showed it as a simple on/off switch. Mysteriously, two days later, Google home shows it as a light dimmer rather than a single mode toggle switch. It appears to be a mysterious glitch on the google home side of the house as nothing has updated changed on HE. Google thinks it's a light now, same as it did on ST, but I can now control it by voice using the 30, 60, 100 commands.

Relatively new HE user here. I migrated from Wink a couple months ago. I have 3 fans using GE's fan switch and I'm really disappointed to see Google Home sees them as lights. I'll say 'thsnks' for the suggestion to put them in a different room but I'm hopping someone develops a better solution.

If the fan capability is ever added to The Hubitat - Google Home integration, then you could. However, if they weren't called lights today, you wouldn't be able to control them at all. So, while not perfect, it is better than nothing at all.

Mostly wanted to add to thread to show there are others with interest and hopefully get a notification if an update is ever added to this thread. :grinning:


I'm new to Hubitat coming over from SmartThings and was disappointed to find my fans showed up as lights. Just commenting to hopefully be notified when this is addressed.

I know I can just throw all my fan devices into my "unassigned" room, but then I'd have to address each fan device by it's full name rather than just saying "fan" in whatever room I'm in.

The only other work- around I've found is to use a smart outlet device driver or to use a custom device driver and comment out the switch level capability. The problem with this approach is that you can no longer adjust the fan level. In smart things, you only had to make sure there was no "light" capability and it would not show up as a light, but it seems that with Hubitat, it shows up as a light with the "switch level" capability.

I think it's a bit stranger and I haven't figured it out yet.

I have one of the original Google Home devices in my office. The office lights (mounted in the fan) are on a Lutron dimmer connected to Hubitat and the ceiling fan has a Smartenit Zigbee (on/off) relay in the canopy to turn the fan on and off (there was no fan wiring to the wall and I didn't want to add it). In this room I can tell Google "Turn the fan off" and it does, responding "Turning office ceiling fan off". Similarly I can turn it on. It never does anything to the lights when I do this.

Do you all think this works because it's an on/off switch instead of a variable (dimmer) type control?

What gets me is I have the same configuration in my guest bedroom except the Google device in that room is a mini. When I make the same request in that room, to the Google device in that room, it turns on (or off) the fan in my office. In that room I have to use the complete name - saying "Turn on the guest bedroom ceiling fan" - and then it works.

The devices are assigned to the correct rooms and my naming convention in Hubitat adds the room name to the device using the same room names as what I have used in Google.

The Hubitat/Google Integration doesn't support Fan Speed yet. It is on the list of things we would like to see but there is nothing the users can do about it.

An alternative method that I use is to set up a applet in IFTTT that has an empty word variable in it.


I then use a link from the maker-api and IFTTT's maker webhooks to set the fan speed to the speed that I have spoken to google home. (I actually use a custom app that fixes some of the common mistakes that google makes when it listens to me but for these commands google is damn good). You can then set up an applet for each fan saying whatever phrase you want to.

Here's an example:

1 Like

Yes. from what I've been able to gather tweaking device drivers, it is actually the "switch level" capability rather than the "switch" capability that is causing Hubitat to show that device as a light. If I remove that capability, Google Assistant works how I want but then I can't control the speed of the fan remotely.

I don't know why it would respond differently in a separate room with the same setup though. especially if you are using the same devices and device drivers.

It really fooled me. Usually if I have a Google home assigned to the same room as a switch or dimmer I can just say "Turn the Lights On" or "Turn the Lights Off" and it will get it. I was happy when the same thing worked for the fan in my office. Then I tried it in the Guest Bedroom. Stumped!

Does this solve the problem of having to refer to each device by name? The way I want it to work (and had it working with ST) is to be able to say "turn on the fan" or "set the fan to (percentage)" and have it control the fan in the room I'm in. But I also want to be able to say "turn on the lights" and have only the lights (not the fan) turn on in the room I'm in. With HE, I can only have one or the other. If I put the fan in the room it will turn on and off with the lights, but if I put it in a separate "virtual" room, I then have to refer to the fan by it's full name.

While it would be nice to say the fan speed rather than the percentage of the dimmer, that isn't what has been bothering me

However thanks for the suggested work-around.

No, that is not possible. I understand how you want it to work. But there is nothing any of us can do about it. It is up to Hubitat to fix.

This is the feature preventing me from making the switch from Smartthings to Hubitat. I've had my hub pretty much collecting dust for almost a year and am really surprised this issue still hasn't been addressed.