Trouble with Dashboard and App (ios)

Hello. Over the weekend I migrated from a C5 hub to a C7. Everything seems to have gone to plan. This was a new C7. I am however having an issue viewing the dashboard on my iOS devices when on WAN. I keep getting an error message: {"error":true,"type":"AppException","message":"Not Found"}. When on LAN, it seems the dashboard works (on my phone, not on my ipad). I've tried deleting and rebuilding the dashboard with no change.

The Hub was updated to the latest firmware and as mentioned, everything seems to have ported over just fine (and works) except the dashboard. I initially built in in the EZ Dashboard but really don't like that style much (and kept getting the error message above). Deleted it and added the classic style dashboard....still the same error.

Any ideas? A definite newbie to Hubitat so it's highly possible I just missed something simple. Oh, not sure if it matters but in the iOS App, when I click on the "Lights/Switches" icon at the bottom of the app, it lists out the Rooms and devices but repeats them like 4 times (ie. Kitchen shows up 4 times....devices are the same but not sure why the rooms get listed more than once)

Appreciate the help!!!

I'd try logging out of the app and back in to see if that helps (Settings tab on your version of the app).

Thank you. I did try that without success. I should have mentioned that in my OP.

any other ideas folks?

I'd try just uninstalling the app, re-downloading it from the App Store, and (after logging back in, selecting your hub if prompted, and selecting the existing mobile app device if prompted--your options may vary depending on your hubs and existing devices) seeing if that takes care of it. The key step is the uninstall that will erase all settings, at least on iOS.

You may want to make sure you're on your home network/LAN when you try this the first time, though I believe it's supposed to work either way (just less to get in the way if you are).

Thanks. I won’t be back to that LAN for another week or two but will give it a go. For giggles, I just tried deleting the app and reinstalling on my lan here at work. Same result as before

I am having the exact same problem and I haven't found a solution that fixes it. Two of the main dashboards that I use now have "EZ" appended to the front of the name but they don't show up in the Easy Dashboard app (why?) and I get the same AppException error listed by cubc. This happens when using cloud links ... it's as if the cloud link to the dashboard has been corrupted, and it's pointing to a non-existent EZ dashboard. I am seeing this behavior while using the Hubitat app on iPhone and iPad.

When I use the local dashboard menu, those two dashboards don't have "EZ" in front of the names and they work properly.

Does anyone know how to correct the cloud links so that they work correctly?

You did a better job describing some of the details than I! I have the same exact behavior between LAN and WAN with the EZ designator. I built my dashboard while on LAN and purposely built it using the older Dashboard App (ie. Not the EZ version). Worked fine on both my iPhone and iPad when on LAN. Once on the WAN, it added the EZ designator and arrows out with the error I previously posted. I use this to monitor things at a cabin in the mountains so until a fix is identified, I’m blind to what’s going on up there (didn’t splurge for the Remote access…never needed it….until now???)

If ANY of your cloud dashboard links for the remote site are working, you could make a temporary work around by adding a "dashboard link" tile to the one that works, and point it to one of the dashboards where the link is broken. Whatever is causing this problem seems to be contained to the main cloud dashboard menu. I can link from one dashboard to another using tiles without any problems. But the big IF is that you have to have at least one reachable dashboard on the remote site.

I also duplicated this error using the cloud dashboard from Chrome on a WIndows PC, so I don't think it has anything to do with the ios app. I can switch to local dashboard and it works fine. I still think there is a broken link that the main cloud dashboards menu is using.

Here are the steps I used to replicate this problem:

  1. From my Windows PC, using Chrome, go to the local hub address (I am running open Dashboards on the left panel menu, click the "Edit device list" icon for any one of the dashboards
  2. Add a device to the dashboard, click Update Dashboard then close
  3. Open the Hubitat iOS app, tap Dashboards icon, now the name of the dashboard I just updated has "EZ" prefix. Why is that ? I don't want to use Easy Dashboards, I didn't explicitly copy my legacy Dashboard to a EZ dashboard. It seems that making any change to an existing dashboard automatically saves it as an EZ dashboard, with no way to reverse that.
  4. The EZ dashboard that was just created now generates the AppException message when trying to open it from the cloud dashboards menu.

Thankfully I found this error before editing too many dashboards or else they would all be inaccessible from the cloud dashboards menu.

@bobbyD I see that was just released and has some notes about easy dashboards, do you know if it fixes the problems we’re having with bad cloud dashboard links? Thank you.

Yes, it should be fixed.

Thank you, I upgraded/tested and the cloud dashboard links work!

1 Like