Tried to update my hub. Now I can’t access it at all and I have a blue light

Ideally you want to set a fixed IP on your router, so that you always know where your hub is, and managing fixed IPs on the router really is the preferred approach for most use-cases.

Many routers allow you to assign a fixed IP for your network devices based on their MAC address (listed on a tag on the bottom of the hub). While you're looking for your hub's IP on your router, if your router supports setting fixed IPs you should consider setting a fixed IP for your HE hub on the router, and then after settting it on the router, reboot your hub and then the hub will come up consistently on that fixed IP address in the future.

Not OP, but also having this problem. A lag started yesterday, noticed my modes weren't switching. I thought maybe a reboot and upgrade to latest FW would help, i couldn't even get into the diagnostic/8081 page, so i did a pull the power reset. Updated FW last night and seemed like it was working. Woke up this morning to the device having a solid blue light with FW:

I guess luckily i have a day off to troubleshoot a bit. I'll contact support, and maybe dig through some logs to see what's happening.

Here are the steps to try;

  • Go to http://your.hubs.ip.address:8081/
  • Reboot the hub from there, see if it comes up.
  • If not, go to http://your.hubs.ip.address:8081/ again, revert to previous version.
  • After it comes up, go to http://your.hubs.ip.address:8081/ yet again and "revert" to version 2.2.5.
  • It's possible that 2.2.5 is not showing as an option at this point. Use Download latest version to get it onto the hub. Doing so doesn't switch to the downloaded version, so once download is done, use revert option to switch.
  • If it still doesn't come up, revert to previous version and let us know.

What if it doesn’t come up and continues to stay blue? No connection at all?

Blue is not bad, hub is accessible and many things can be done.

Did you see/try the steps just above your post?

My Hub stopped working after a few weeks. It was off one day, and never came back on. USB power worked, tried on another USB cable and adapter, no light, nothing. I returned it to Amazon for a replacement. The new one worked. I tried to update it, but it did not reboot, and the GUI did not come back.
I tried upgrading from port 8081, rebooting, downgrading, rebooting, reverting to new version, rebooting, nothing worked. I went through this cycle about 6 times, and it never worked.
Finally, I decided to try one more time with Firefox browser instead of Chrome. It works! IDK if I got luck on try number 7, or it actually worked before, but Chrome just showed me a cached "connection refused" page.
Or it could be the new firmware. Yesterday I was trying to get to work, today it's running