Time based apps/pistons/devices not working after brief power outage

Had a brief power outage yesterday due to a thunderstorm and noticed some things are no longer functioning correctly. I have pulled power and rebooted the hub, but no change. Examples below:

  1. Virtual switch with "enable auto off 5s" set, does not turn off after 5 seconds. Shows a scheduled job pending to turn off, but it never completes.
  2. webCoRE piston: change color of LED strip every 10 seconds. The strip turns on and chooses random color, but never changes color after that. Piston log shows a scheduled job setup for 10 seconds later, but never does anything after that.
  3. Multiple lights are supposed to turn on everyday at sunset but they never turned on yesterday.
  4. Zwave poller app stopped polling after power outage.

All of these worked fine before yesterday.

Check the clock under Settings > Hub Details

This sounds very similar to an issue I solved for someone else. They had some Wifi devices integrated that were offline and the poorly coded driver kept hammering the IP trying to connect. It was causing exactly as you describe where rules would start but never finish, and automated lights were not always turning on (or they would turn on but never turn off).

Check your logs for any warnings or errors.

Make sure all your Wifi / LAN devices are connected and have the Same IP, and that the integrations are making a connection.

Thanks. I checked the time and other details on that page, everything looks correct. I checked a few other things, and ultimately did a hub database restore from yesterday morning. Everything is operational again, so problem solved. Thanks!