ThirdReality Switch

I bought one of the ThirdReality switches to control my gas fireplace where the switch is in an awkward location. I paired it right away yesterday and added the Generic Zigbee Switch as suggested in the Device list, however the switch did not work through HE, only when pressing the button.

I thought maybe I did something wrong with the initial pairing so tried again. I removed the switch and have tried repairing multiple times but the device is not found.

I now know I probably should have tried other troubleshooting steps before unpairing. Are there any suggestions on what I can do to get it discoverable again? I have removed the batteries each time before attempting to repair.


Which version (Gen1 with metal plate or Gen2 that is all white)? How many Zigbee devices do you have? Are any of them repeaters (such as smart outlets)? How far is the switch from the hub? If you bring it near the hub, does it work?

As for discoverable, remove the batteries and press the button several times to ensure that all residual power to the circuit board is drained. When you insert the batteries, the light should blink. If it doesn't, try holding the button down for 30 seconds. That is what the site states about putting it back in pairing mode.

As for HE, when you paired it, it was detected as "device." You wrote that you changed it to "Generic Zigbee Switch." Verify that it took when you configured it. Tap "Configure" on the device page. Then test it with the Off and On buttons there. It should operate. This is with the 3R switch near the hub. If it works, test it with the button on your dashboard which should be your 3R switch set to use the "Switch" template.

If everything works when it is near the hub, then it is possible that it is too far from the hub to get a signal, especially if there are multiple walls between the hub and the device. In that case, you would need one or more Zigbee devices that can act as repeaters to help get the signal to the switch. Things that have constant power such as smart switches can act as repeaters. Purely battery operated devices can't.

Thanks @StephenH. This is Gen1 and I have a few Iris outlets that can be used as repeaters but they are not in use currently. I am pairing less than 10 ft from the hub and have also placed the switch right next to the during pairing mode. If I get it working it will be about 20 ft from the hub in the same room.

I did not configure after changing the driver which may have been my original issue. But now that I have removed it I cannot test. The device does go into pairing mode based on the blinking light, it is just doesn't get discovered by HE.

Since it seems to be going into pairing mode based on the light indicator, I am hesitant to contact ThirdyReality until I have attempted more with HE. Sorry, I just got HE last week and it was probably my error with the first pairing, and removal that has created the issue.

Question: Did you remove it from the Hubitat device list? It may be that it can't be paired since it already exists in Hubitat. Please check and remove it from the device list and then try pairing again. If the outlets are gen 2, then they can be used (and should be given what you said). If they are gen 1 outlets, they won't work just yet. I understand that may change but for now, you need gen 2 outlets. They will help build a robust Zigbee mesh network which sounds like what is currently lacking.

I confirmed it was off the device list immediately after removing and before I tried to pair the second time. I checked a few more times since the pair was not working and again just now, it is not showing up in my device list. Yes, the outlets are v2 so I will plug them in.

Try restarting your Hubitat. Go to Settings and select "Reboot Hub" and then try pairing again. Now is a good time to mention that if you do not have a battery backup for your hub, it would be good to look for one. Like all modern computers, the Hubitat does not take kindly to being abruptly powered off without being properly shut down.

Ok, so is there an issue if I did the reboot, and hub is now green, but it still shows as Hub Rebooting on the settings page? Is it complete and the page just hung? Been about 10 mins.

Can you switch to your Devices or Dashboard page?

Yup, and went back to settings and rebooting disappeared. I'll try to pair again.

That worked for pairing! Now I want to make sure I do the next steps correctly. Type is currently listed as Device, which I believe I need to change to Generic Zigbee Switch per the Supported Devices doc. However you said I should configure after the change. I do not see that on the device page, where will I find it? Sorry, trying to step through slowly to not mess things up again.

On the Devices page, look for the switch. Click on that device name and it will open up a new window with the configuration options. Scroll down to where it says, "Device Information." It is there that you change the Type to "Zigbee Generic Switch" and then change the device name and label if you wish. Finally, click "Save" so that you will make the new settings permanent.

Scroll back up and click "Configure." Then you should be able to click "Off" or "On" and check to make sure the switch is activating. Then it is time to move it back to the location you need after you also get your outlets (Gen 2 since Gen1 won't work) paired and placed between the hub and fireplace. They will help build your Zigbee mesh network.

Thanks Stephen. That worked, and I probably knew where it was if I thought about it, but again I was playing it safe (didn't want to touch anything without knowing exactly what to do.) I already placed a switch in the same room so that should help.

Thanks again for your help on getting me through this. The Dev and community support was the main reason I chose to move to HE.

That was a big reason behind my decision as well. I have seen over and over with different products that the support community can make or break the experience.

Great! I'm glad you got it working. The community was also a factor for me. It is the same way with our R-Pod camping trailer. The forum there has been most useful.

Does anyone have experience using the Gen 3 switch with HE?

I had a Gen 1 connected to SmartThings a few years ago, but quickly returned it because I was having to change the batteries every week! Before I take the plunge on buying a new one to pair with HE, I wanted to hear from others who have used this device. Also, does anyone know of any similar devices that use Z-Wave? I have no Zigbee devices currently, so I'm concerned about reliability.

I'm running 1st & 2nd gen, 10 or more total. The 1st gen ran on eneloops for a while but I converted them to usb. IIRC, they would run about 4 months on the rechargeables. One of that group was on a motion sensor in the garage and had a dozen or more cycles/day.

I have 4 of the 2nd gen in the kitchen currently running on eneloops. These are cycled as a group, probably 5-6 times daily. Batteries lasted about 8 months, maybe more.

Antennae range seems mediocre, but they have been very reliable.

I should add that I could not get them to work reliably on older toggle-style switches. But no problems on paddle-style once fitted & adjusted.

What's an eneloop?

Eneloop is a brand of 1.2-volt nickel–metal hydride rechargeable batteries owned by Panasonic. Very long life, highly recommend.

1 Like

I've had mine running for quite a while (since 2019). I've been through one set of alkaline batteries. It has been a solid performer for the most part. I did have one instance of a discrepancy between it and the dashboard once. It had somehow gotten changed so that off was showing as on and on as off. I forget how I got that straightened out, but I did. That wasn't a switch problem as such. It works well with the toggle switch. The only down side is the motor noise when it turns on and off.