Third Reality Shade Stop Position Problem

I am having a problem with my stop position change. This one shade refuses to work properly. The 0 position is 23% short of the actual closed position. I have tried every combination of settings in the device settings but I cannot get the zero position to equal the actual closed shade. Physically closed is -23. Can anybody help? I have removed and reset this shade multiple times but it keeps doing this. Attached is a picture. The shade is physically closed (Had to use the buttons on the shade itself.)

I have several Shades that lost their settings, some more than once. I believe it is a Third Reality problem, not a Hubitat problem. I haven't explored better ways to re-calibrate the hardware other than to take the battery out and re-pair.

I have two of these next to each other to cover a bigger window, and these are the 2 zigbee devices currently giving me fits... Hard to know if it's an HE issue or a 3R issue, or some unfortunate combination of both. But I suspect it's a HE issue, since these were performing fine overall before moving them to my C-8.

I'm going to try to remove and re-pair them yet again here...

I was having a similar problem (not with C8 yet). I contacted Third Reality and they suggested that I update the firmware. It worked like a charm after I did that.

I created a post about how to use the remote. If firmware doesn't fix it, it's the only way to do it.