Thermostats not working in Dashboard 2.0

I have C8 ( and my thermostats are Stelpro. They are working fine in the previous dashboard but not at all in 2.0



I did not find a solution in the forum. Any idea ?

They've identified an issue with the mode attributes in some thermostat drivers being out of order. It will be fixed one way or the other. They identified the reason though.


Thank you for your answer !

If your thermostats are Stelpro Zwave KI, I modified the driver to fix that.


Did you remap the orders?

No. The thermostat has only one setting: "heat"... no "off", no "fan", no "cool". I added fake ones.


I'm using a different driver. Where is your driver since it seems not to be in HPM ?

1 Like

@samuel.c.auclair Can you fix this in your sinope driver? (see a couple of messages above for @ymerj's solution for his..

It works fine thank you. I have one Stelpro Zigbee, you don't have the driver for it too ?

Sorry no. But if it is the one used for Hilo, @mboisson made one for it.

It is the Stelpro Maestro zigbee.

I'm no longer actively maintaining the driver, but will look at it this evening since it does not seems too complicated


Thank you!

Same issue when using the Honeywell thermostat drivers.
But somehow, someone has something working, because this post:

shows a Honeywell T-stat.
@WarlockWeary - how are you getting your T-stat to show in the new dashboard??

Not sure .. I tried a few times and deleted readded it ..
I got the same thing as the OP when I tried .. got a :(( face Icon
It just started working LOL I think if you change anything about it it stops working.
Not sure though sorry ..


I will probably run into this issue with the Stelpro Allia driver that is heavily inspired from yours, so I will eventually fix it there too, but I don’t have time to look into this until June. I am still running 2.3.8.

It's the mode attribute order in the driver. This is an issue is some community drivers and a few native hubitat drivers. Hubitat is aware.

I'm having the same issues with MCO HOME thermostats that are running with Generic Z-Wave Plus Thermostat driver. Sometimes they are running fine a few seconds but mostly without any info.

Zxt600 has the same problem, was working now not with error,

Missing Attributes: