Thermostat tile not working to set mode and fan

I have an Iris thermostat that I just hooked up today. I put the new tile on my dashboard and started messing around with it. I can set the temperature up and down just fine, and I can take the fan from On to Auto but not the other way around. I cannot change the mode at all. When I go to the device page itself, I can change everything just fine. When I change modes and fan settings on the thermostat they update on the tile. I just can't get the tile to change modes and the fan from Auto to On.

I'm having the same issue. This has been broken for months. I just updated to hoping it would fix it, but it's still broken. When you try to set the fan mode to 'On' from a dashboard you get this error in the logs:

[dev:34]2019-11-30 11:44:46.613 am [debug]' on' is not a valid fanMode

[dev:34]2019-11-30 11:44:46.598 am [debug]setThermostatFanMode( on) was called

It looks like the dashboard app is prepending a space to the "On" command.

On a separate note: It would be really nice if you could manually enter a temperature rather than having to push the up or down arrows several dozen times, waiting 1-3 seconds between each button press.


1 Like


I am having a similar problem. I am running the current latest software (v2.2.0.131). I'm using Honeywell T6 thermostats, and I've tried both the built-in driver and the "Advanced" community driver. Both, however, with the built-in dashboard tile. However, for me it seems that setThermostatFanMode(on) is called correctly, but the other two options (auto and circulate) are not. Here are the logs:

[dev:90]( 09:13:06.220 pm [info]( fan is on
[dev:90]( 09:13:06.218 pm [debug](, off:false), desc:zw device: 09, command: 4403, payload: 01 , isMulticast: false
[dev:90]( 09:13:05.508 pm [trace](
[dev:90]( 09:13:05.503 pm [trace](
[dev:90]( 09:13:01.771 pm [trace]( circulate)
[dev:90]( 09:12:56.718 pm [trace]( auto)
[dev:90]( 09:12:38.071 pm [warn]( logging is: true
[dev:90]( 09:12:38.068 pm [warn]( logging is: true

It seems like setThermostatFanMode(on) is now correct, but there are still incorrect spaces in setThermostatFanMode( auto) and setThermostatFanMode( circulate).

I am also having problems with setting the thermostat mode to auto. The other modes work, but the auto mode fails to switch in the tile, saying, "auto mode is not supported buy (sic) this thermostat". However, it is supported, and the setting to enable auto mode is on. It's called "Auto Changeover" in the user manual. It also fails from the device page in the same way. Here are the relevant logs for setting the thermostat mode:

[dev:90]( 09:37:02.659 pm [debug]( mode is not supported buy this thermostat
[dev:90]( 09:37:02.657 pm [trace](
[dev:90]( 09:33:32.515 pm [debug]( mode is not supported buy this thermostat
[dev:90]( 09:33:32.509 pm [trace](
[dev:90]( 09:33:29.036 pm [info]( thermostatSetpoint was set to 70.0°F
[dev:90]( 09:33:28.997 pm [info]( mode is heat
[dev:90]( 09:33:28.994 pm [debug](, desc:zw device: 09, command: 4003, payload: 01 , isMulticast: false
[dev:90]( 09:33:28.317 pm [trace](
[dev:90]( 09:33:28.315 pm [trace](
[dev:90]( 09:33:24.789 pm [info]( mode is cool
[dev:90]( 09:33:24.786 pm [debug](, desc:zw device: 09, command: 4003, payload: 02 , isMulticast: false
[dev:90]( 09:33:24.086 pm [trace](
[dev:90]( 09:33:24.082 pm [trace](
[dev:90]( 09:33:20.386 pm [info]( mode is off
[dev:90]( 09:33:20.377 pm [debug](, desc:zw device: 09, command: 4003, payload: 00 , isMulticast: false
[dev:90]( 09:33:19.544 pm [trace](
[dev:90]( 09:33:19.542 pm [trace](

Once I change the driver to the Advanced community driver, setting the mode to auto works correctly from the dashboard and the device page. Again, the relevant logs:

[dev:90]( 09:43:18.121 pm [debug]( thermostat mode: auto
[dev:90]( 09:43:18.118 pm [debug]( thermostat mode report: ThermostatModeReport(mode:3)
[dev:90]( 09:43:18.112 pm [debug]( device: 09, command: 4003, payload: 03 , isMulticast: false
[dev:90]( 09:43:17.675 pm [debug]( zwave thermostat mode 3
[dev:90]( 09:43:17.674 pm [debug](

Unfortunately, the fan mode settings don't work from the dashboard for either driver. It looks like a simple fix: there are spaces in the command that should not exist.

1 Like