Thermostat Scheduler Error After 2.2.2 Update

I now get the following error when trying to open either of my Thermostat Scheduler apps:

Unexpected Error
An unexpected error has occurred trying to load the app. Check Logs for more information.
Error: Cannot invoke method replace() on null object

This is in the logs:

app:8032020-07-16 10:31:42.102 am errorjava.lang.NullPointerException: Cannot invoke method replace() on null object on line 1145 (mainPage)

I'm getting same error after this update.

1 Like

I get the same error message when trying to open the Thermostat Scheduler app.

I also get a similar error with Button Controller. I will open a new thread and include logs re: the Button Controller app. Thanks.

Just in case this thread hasn't been noticed by the HE team, tagging @bravenel.


I would insert my "this is why I don't upgrade my production hubs for a week or so after a new release" mantra, but I don't want to be cheeky. :wink:

1 Like

Sorry about that. Fix coming in next release.

Could you show screenshot of your Thermostat Scheduler main page so I can verify fix?

1 Like

I can't get to the main page. The error comes up as soon as I click on the app to open it.

Same here.

Ah yes, never mind. I know what the problem is. Your thermostat doesn't support the attribute supportedThermostatFanModes. Fix coming in next release.


scheduler at least seems to still be running

Yes, it's a UI problem. Fix coming today.


Issue has been resolved with latest fix. Thanks @bravenel.

Working again for me. Thanks @bravenel.

....same here. Thank you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.