Thermostat Scheduler Auto Mode

I'm using Honeywell thermostats and I'm unable to get the thermostat mode into Auto on the scheduler. It lists Cool, Heat, and Emergency heat. I was using the Honeywell driver but switched to the Generic ZWave driver to see if that would work.

Living in SE Texas there are days we have to run the AC in the morning, heat at night, and back to AC the next day. I really need Auto Mode to work.

Anyone have a fix for this?

Show a screenshot of the thermostat device page where it shows Current States. It may be that the thermostat doesn't support Auto mode. Have you tried setting it on the thermostat itself?

Thanks for your reply... You were correct that "auto" was not in the list of supported modes even though it should be. I started chasing rabbits and found another post where you change the thermostat driver to virtual, set the modes you want, then change it back to Honeywell driver. That worked beautifully!

Thanks for your help!

1 Like

I am having the same issue with the Honeywell stat. I can get it into Auto mode from the stat itself, but it doesn't show up in the options in the driver. Can you send a pointer to the post you saw about switching to virtual. I tried this with no luck, but I might not be doing it right.

TIA.

Show the Current States from the thermostat device page.

When I manually (at the stat) turn it to auto mode, the current state shows up as auto. Auto is not an available state in the thermostat state dropdown. It's also not available in a thermostat scheduler. I don't get auto, just cool and heat (as well as off and emergency heat). When a scheduling event happens, the stat changes from the manual setting of auto to what the scheduler has it in it - only cool or heat.

Please show the Current States with a screenshot. Device page

There is most likely an easy fix for this, once you can show that...

See image. Thanks.

You can see that auto is not a supported thermostat mode. If your thermostat actually supports auto, then you can fix that (this is a driver shortcoming).

See this post: Thermostat scheduler unable to set fan or mode - #5 by bravenel

What you need to do is change supportedThermostatModes to this (you don't need to change supportedThermostatFanModes):

["off","heat","cool","emergency heat","auto"]

Thanks for that guidance. While I was able to make the changes, the stat is not responding to the "auto" mode. It's strange because when I manually change the stat to auto (again, at the stat), thermostatMode shows "auto" as the setting in devices (the dropdown for Set Thermostat Mode still does not show auto, BTW). That was the case even before I made this change.

If I use the thermostat scheduler, setting the stat to auto mode and adjusting setpoints, the stat doesn't respond. Like it's ignoring the command. The current mode remains. So, even though the stat has an auto mode which can be set on the stat, itself, the driver doesn't seem to be able to do that.

Honeywell describes their auto mode as "auto change." But the setpoints are for heat and cold. The auto change thing would seem to apply to a single setpoint for a cutover between heat and cold, with some obvious builtin separation.

In the thread you sent, one responder switched to the Generic Z-wave thermostat driver. Is that worth a shot?

Again, thanks for the time here.

I think I got it working. I switched to the Generic Z-Wave Plus Thermostat driver and all appears to be working correctly. Thanks for all the help and fast response!

Download the Hubitat app