Thermostat Scheduler 2.0 - Zwave - Stelpro Ki

Hello all - Just transitionning from Smartthings to Hubitat -

I am testing each devices one by one - Stelpro KI (Zwave) is my next move. I managed to upload the Smartthing conversion that was posted in the forum. I can now see Setpoint and current temperature. My next move was to try to control the thermostat. So I decided to add the Thermostat scheduler as per the screenshot below. I am having a null pointer error on mainpage. This seems similar to some other post for the Zigbee version, but not sure where to start... if anyone has an idea... I'll appreciate.


For some reason, I believe it is related to the fact that when selecting the thermostat - (there is only one Sophie-Th) it does not fill the field with an *.... therefore the code cannot create the child with a nul ( space ) name....

Just trying to figure out what the hell.... :slight_smile:

This is probably caused by a deficient driver. Could you show the Current States from the right side of the device page for this thermostat.

What Release are you using. You should update to the latest:

Thanks for the fast reply.

Yes - I updated to the latest version of Hubitat
I added full screenshot of the device.
The driver is the one posted on the community by Josh Conley


Show the full url from the top of your browser window for Thermostat Scheduler you showed in the first post.

Here u are.

This is caused by the driver. Your thermostat device has no thermostatMode attribute, as shown in your Current States screenshot above. Have you tried setting the thermostat mode with the tile on the device page? Your Current States should show a thermostatMode like this:

The app is choking on not getting a mode back from the thermostat. That should be protected against, but that is the cause of this.

Thanks. 1 bug to 1 :slight_smile:
I'll try to make sense of what you just gave me.
My Groovy skill's are far from being optimal, not to mention my Zwave knowledge.
Time to learn :slight_smile:

You don't need any Groovy. Just hit the Set Thermostat Mode tile on the device page with any selection for what mode you want the thermostat to be in.

Screen Shot 2022-10-15 at 5.29.46 PM

Only if there is no value showing on the right side under Current States for thermostatMode would you have an issue to deal with in the driver source.

Thanks. This is more like it

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.