Thermostat Modes List is empty


Finally I decided to update my C-7 to the latest and immediately
stepped into a problem. All my RM 5.1 rules related to the Thermostat showed
*** Broke Action *** for former Thermostat settings actions.
So, I delete these Broken Actions and tried to re-enter them back but
list for Thermostat Modes is empty:

Of course, there is nothing in a log. Rule simply cannot be added.

Everything was working just fine on before the update.

What is my option(s) for fixing my now broken rules except for the
restoring previous platform version?

And now I am wondering what other "surprises" I may find after the update?

What thermostat is this, what driver is it using, and--most importantly--what does "Current States" look like on the device detail page for this device? There have been a few reports of this recently, and it's normally an issue with the driver as described in this post.

1 Like

Please answer @bertabcd1234's questions. This is easy to fix.

The Dice Page looks normal/OK, Driver is "Generic Thermostat Driver".
This is latest Ecobee 5 Thermostat added to the Home Assistant via Home Kit Controller
and exposed to the HE via Home Assistant Device Bridge (HADB).

All controls and status reporting is 100% functional from the Device Driver page.

I am check the suggested post but I am not sure how this could be applicable
to my case. Before even reading this post I created a Virtual Thermostat.
It looks like I can fix my problem by selecting both Thermostats in my rules.
Just tried this as quick check. This seems to be working as expected and logs
do not produce any errors.
Should I consider this trick as a fix or there is better real fix for this problem?

It doesn't, actually. It's missing the supportedThermostatModes (and supportedThermostatFanModes, though that's not your particular problem) attribute, as required by the Thermostat capability. I'm not intimately familiar with the HADB integration, but I assume it's using some sort of component driver, and the app or driver that creates this device will need to set the value of these attributes appropriately.

Alternatively, if it lets you change the driver, you can use a slightly awkward workaround by temporarily changing the driver to something like Virtual Thermostat and running the "Set Supported Thermostat Modes" command (and, again, probably the similar one for fan modes) yourself.

This is nearly the same as the workaround that Bruce also describes in that thread in this post: Thermostat scheduler: Unexpected error: Lexing failed on line: 1 - #7 by bravenel (except your issue is modes, not fan modes--but might as well do both; adjust the values as needed).


OK, you are correct, these Attributes are/were missing.
Yes, HADB brings HA Devices to HE by assigning whatever Component Driver.
In this case it is "Generic Thermostat Driver:.

This did a trick.
Thank you very much for the very quick response and fix for the problem!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.