Thermostat controls don't appear

I am having an issue where one of my thermostat control tiles won't display the temp up/down controls. it works for an identical device in one room, but doesn't display correctly in the tile for another ! image|690x125 The devices are the same exact, but one won't display. any ideas?

Sorry, here is the screenshot

If you create another dashboard with the same two devices, does this still happen?

I have the same issue, ended up having to create a couple virtual buttons to control it. If I make a new dashboard and create a thermostat tile it works fine but on this dashboard if I delete and recreate it has no controls. If I copy the layout in the advanced tab for faulty dashboard it ends up with the faulty thermostat.

1 Like

Yes, still happens. I also did a side by side comparison of all the device details and they are the same. I am going to remove and re-add the offender and see if that fixes it.

No luck, removed and re-added but no control. So strange that the exact same device would behave differently...

Compare in the driver details page. Sometime you need to press configure to get all the status details.


can't find the driver details page

Try going to the device page and clicking the Configure button. Then recreate the Dashboard tile. It's very likely that @Navat604 Is on the money.

I have only the one thermostat and If I create a new dashboard and make a thermostat tile it works fine and controls are there. My main dashboard though doesn't have the controls and if I delete the tile and recreate it, it still doesn't come up. Tried the configure in devices anyway but had no luck, thanks.

I can just create a new dashboard and start from scratch but finding time to redo it all is the issue at this time of the year.

Try removing the device from the dashboard app altogether and re-adding it. Not just removing the tile.

(newbie here--if not clear already) I can see how to remove dashboards, but not how to remove individual devices from the dashboard app

Same menu where you add devices to the dashboard. Just uncheck it.

ok, so I pushed configure, gave it a heat set point, pushed poll and refresh and now it is working (in all the dashboards now)! not sure which of those made the difference, but so glad! Thanks to you all for helping! Sorry I didn't do one at a time to give better feedback on the solution...


For me, I had to set it to Heat mode before, and then pushed configure, heat set point, refresh and everythings OK after !