Thermostat Controller - "Unexpected Error" Problem Upgrading to Latest Hubitat Version (From 2.3.2 to 2.3.3)

Today I decided to upgrade my Hubitat to the latest version and start using the new and improved Thermostat Controller app. The upgrade to from 2.3.2 to the latest version of 2.3.3 went perfectly smooth. Everything worked as it did before. But then I decided to completely delete my old Thermostat Controller app and all the old child devices that appeared anywhere else.

All seemed fine until I tried to re-install and set up the Thermostat Controller app.

Here's what happened:

  1. Go to Apps> Add Built-In App> Select "Thermostat Controllers".
  2. Click on "Create New Thermostat Controller".
  3. Select the Thermostat I want to control.
  4. Then I get the dreaded "Unexpected Error" message. Sometimes it lets me select the thermostat I want to control, and then gives me the error message.

Here's the exact error message:
## Unexpected Error

#### An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: No signature of method: is applicable for argument types: (java.math.BigDecimal) values: [68.0] Possible solutions: wait(), any(), wait(long), take(int), any(groovy.lang.Closure), each(groovy.lang.Closure)

I tried this several times, rebooting the Hubitat hub, selecting different thermostats to control. Same results every time.

I have no idea what to do. Please help.

I have included screenshots below showing the error message and some logs. I hope these will be helpful. I have no idea what they mean.

Here's the Error message:

Here's what I see when I click on "Logs."

Here's a log of one of the thermostats I was trying to control:

@bravnel, any help you could offer would be greatly appreciated.

@BobbyD, can you offer any advice or connect me with someone who can help?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.