The need for Metering is back

I just updated C7 firmware from .136 to .140. I have one rule that turns OFF about 22 devices. That rule has become unreliable and leaves random devices ON. Nothing has changed in my setup except updating the firmware. I tried a 5 min power off in an attempt to clean any radio weirdness but it had no effect.

For probably a year I was using Bruce Ravenel's "All Off" app (which has metering and retries) and it worked like a charm. Months ago I read here that metering is no longer necessary with the latest zwave radio update so I removed the app. But now it seems the problem has returned.

1 Like

Did you actually run the z-wave update? It's separate from the platform update

Yes I did update some months ago. Is there a new one and how do I check version?

Go to the Z-Wave details page on your C7 Hub.

Look at the article linked here and check button D, if it appears it means there is an update available for your C7 Hub Radio.

Firmware Update button does not appear.

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

@JoeJ Are you saying that the meetering option is gone in .140? I don't see that in the release notes. If so, I won't upgrade. This is essential to me.

Metering was never removed from any app that had it (Groups and Scenes and Rule Machine custom action, off the top of my head) -- just not added to any new apps (e.g., Room Lighting). I'd probably look into any device or network issues first, but if there's truly a need in your environment, both of these options and possibly others are still around.


Can you post a screenshot of your z-wave details page?


Coincidentally, I just made a Simple Automation Rule that turns all the lights on and off from a Zen34 button switch. They all turn on and off, and I've tried several times. It takes a little while, but none have been missed, knock on wood.
edit: I too am running .140 on C7.

Okay, I know you guys are kind of writing me off and saying it's my problem with the network, mesh, etc.

All I know is that my setup was working perfectly since I set it up early this year. Then I updated to .140 and it broke. Perhaps there is a way to downgrade to a previous version as I would rather do that than use this metering kludge.

1 Like

I don't feel like anyone is writing you off, everybody is just trying to help you get to the bottom of the problem, a mesh is a living thing that changes all the time, you might have a device that is acting up and causing problems on it and could be the cause. We are all just here to help!


Mesh Details

Can you also post the rule?

It's a pretty simple rule using the button controller:

Well that's a nice mesh...

Can you come over and get mine to look like that? :smiley:

All 100k, decent RTT averages, decent Neighbor counts, and low numbers of route changes. Zero ghosts. Well done.

1 Like

My guess is he lives in a small cardboard box. :wink:

Or is a beneficiary of the external antenna path.

If not either, then I'm equally impressed.

Thanks- it only became this good after I did the antenna mod.


Maybe trying it with a Simple Automation rule could narrow it down?

1 Like

I'm already using a rather simple Basic Rule for this: If a button is pressed, turn off 22 devices (consisting of 15 dimmers and 7 switches).

It's just not reliable after I updated from .136 to .140. I went back to using metering, and everything works okay now. Perhaps this bug will be discovered in the future and fixed in a later release.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.