Tasmota Hubitat Driver & Sonoff RM433 Remote Controller

Hi Guys,
I've just recently installed the Tasmota Hubitat Driver and must say, awesome job incl I truly appreciate all the hard work related to programming the drivers for Hubitat!

So far I've added 1 x Sonoff RF Bridge (flashed with Portisch for RF's 433HMz TxRx) and 1 x Sonoff 4CH Pro, flashed both with Tasmota v7.2 with virtually no dramas whatsoever.
Next I used the Tasmota Connect App in HE to add them both as Parent Devices, pls see attached screenshot.

I was able to learn a single 433MHz button into the RF Bridge, create a simple rule in RM that would trigger the 1st relay on the 4CH Pro and turn on one WiFi Yeelight with a single press and turn both off with another single press, happy days.

Then I tried learning a Sonoff RM433 - 433MHz Remote Controller which has 8 buttons that need to be, as far as I understand it, programmed individually for each of the eight buttons.
The RF Bridge was in Learning Mode with the RAW option enabled but it all started to go pair shaped from there when my brain proceeded to turn into mush,

There's support information that documents the need to capture the B1 info and convert to B0 which is & isn't where I start to get lost, it's in this link below...

It says to press the RF Buttons multiple times, seperately, in order to capture the info required but also to obtain the RF Codes for each individual button and after I do this, capture the data, save it and finally refresh the device page to see the State Variables, it only shows one state, not 8 states as in one state for each button.
I though being an RF Bridge, it would show seperate State Variables to use with say RM but that's probably my fault for assuming this :crazy_face:

Anyway, I hope my long dribble has maybe made some kind of sense??

If anyone could help pointme in the right direction it would be greatly appreciated!!

Anyway, I hope my long dribble has maybe made some kind of sense??

Not really are you just trying to save each of the button pushes fro the remote?

Yes, pretty much

Next time, just tag me :stuck_out_tongue: Or write in the driver thread :wink:
First, I'm aware that the instructions for that driver is lacking... I'm working on making it MUCH easier to use... With that said...

Forget about B0 and B1, that is for sending RF commands FROM the RF Bridge, that is not fully implemented in the released version.
In your scenario you need to set "Number of Children" to 8 in the Parent driver, then do as you did for the first button for each child (learn the Toggle command in each child device), that way you'll end up with one toggle switch for each button.
Hope this helps, otherwise, just ask again :stuck_out_tongue:

I'll give it a go and let you know how I go.
Thanks mate for the quick response!!
BTW, love your work.
Really appreciate the time you've put into the HE's custom apps & drivers.
Again, Thankyou.

FYI, I hope my initial post didn't come accross as negative in any way?
I just wanted to provide as much info as possible before posting to save time for others asking questions to answers I could have provided in the first place.

No, not at at all, it's more that it was by pure chance I saw this, not often I just browse the forum for new posts...

That's great, it helps and usually cuts down on time for everyone! I hope you get it to work, if not, just ask again :slight_smile:

I worked a treat, Thanks heaps for your support.
Funny thing was, I actually did change that option to 8 additional child devices but nothing changed. It wasn’t until you suggested it but this time I clicked the button to rebuilt child devices that it worked.
Anyway, happy days.
One thing to note FYI, because I want the Sonoff wireless buttons to trigger my RM Pro to change HDMI inputs, power on/off various devices via IR, I’ve found that if I create all 8 rules in RM and then when finished programming all 8, not all the buttons work.
I found a workaround.

  1. I start in the RF Bridge by learning the individual button in the child
  2. Delete the existing IR Code then Re-learn it in the RM Pro Hubitat App
  3. Go to the rule I created in RM and delete out any settings, triggers, actions & conditions.
  4. Setup the rule almost from scratch, only the name and empty rule remain. Then last thing before clicking the final Done button is Update The Rule, then click done.
  5. After that I test the button and it works flawlessly every time.

You're welcome, glad it's working!

It sounds like there might have been a change of devices (ie, child devices removed and added again). The RF Bridge driver does not do that unless a device is manually removed or you press "Delete Children" (this is a dangerous button, in my next release this button is hidden until enabled in Preferences).
As for the RM Pro App, I don't know if that one might do something similar or if it removes/recreates devices when making changes? RM rules break when devices are removed... So does any app, in one way or another, that use a device which is deleted. At the very least the App/RM rule can't control the device anymore, since it is actually a new device.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.