T6 Thermostat with TStat scheduler

Hi guys @bravenel and @bcopeland , I apologize if this was brought up elsewhere but after searching and reading a lot of threads I cannot find an answer. I'm running a brand new T6 thermostat with the built in T6 Pro driver and the TStat scheduler app. I'm using 'modes' for setting the setpoints and the setpoints from the scheduler app are not getting applied to the thermostat. The device screen and dashboard work just fine it's just when the scheduler attempts to change the setpoint.

I had the logs turned on and everything looks like it should be working but one thing I noticed is that the scheduler uses a decimal setpoint instead of an integer. When I adjust the SP with the device page or dashboard the logs indicate setCoolingSetpoint(xx) and T6 responds right away with the new setpoint (the reply is decimal but not the command), When the scheduler does it the logs indicate setCoolingSetpoint(xx.x) which the T6 ignores and never acknowledges. I think the T6 does not like the setpoint command as a decimal as that's literally the only thing different in the logs. Is this something you've maybe seen before or can check to see if the decimal is a problem? I can't see any other difference in the logs. Thanks!

That sounds like a driver bug.. I’ll check it out..

Thanks!

Ok.. I am not actually able to reproduce this.. Are you sure you are using the built-in driver?

My testing was with thermostat scheduler and the built-in Honeywell T6 Pro Driver

From my testing:

2021-08-19 12:28:36.809 DEBUG   dev|25|Kitchen Thermostat|setCoolingSetpoint(71.0)
2021-08-19 12:28:37.442 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat coolingSetpoint was set to 71.0°F
2021-08-19 12:28:37.445 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat thermostatSetpoint was set to 71.0°F
2021-08-19 12:32:00.065 DEBUG   dev|25|Kitchen Thermostat|setCoolingSetpoint(65.0)
2021-08-19 12:32:00.662 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat coolingSetpoint was set to 65.0°F
2021-08-19 12:32:00.665 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat thermostatSetpoint was set to 65.0°F
2021-08-19 12:32:42.380 DEBUG   dev|25|Kitchen Thermostat|setCoolingSetpoint(65.5)
2021-08-19 12:32:42.968 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat coolingSetpoint was set to 66.0°F
2021-08-19 12:32:42.971 INFO    dev|25|Kitchen Thermostat|Kitchen Thermostat thermostatSetpoint was set to 66.0°F

Hi @bcopeland , Thanks for your help.

Yes, here's the device info.

Here are the logs for changing with the dashboard or device page.

Logs when the Scheduler attempts to change the setpoint.

You can see in the 'good' logs, setCoolingSetpoint(72) and setCoolingSetpoint(73) are pretty much immediately accepted. But the setCoolingSetpoint(76.0) from the scheduler is ignored. This is repeatable.
Is there a setting in the TStat that maybe I'm missing? I have it set to ZWave advanced reporting, that's about all the 'customization' I did. Since I wanted HE to control everything I really just set the time and basic configs (single stage, gas, etc).

Hi @bcopeland, I found more info... unfortunately it makes it more confusing. But it is repeatable. The setCoolingSetpoint() with a decimal does work but only when setting it manually with the scheduler. I used the manual 'hold' settings and set the setpoint just like your logs and it all worked fine. But when I reverted back to 'schedule' mode the setCoolingSetpoint() was ignored. Here are the logs.

'Hold' SP changes, worked fine.

'Schedule' SP changes are ignored even though the setCoolingSetpoint() command looks the same.

I'm baffled at this point, hopefully it will point you in a direction to locate what the issue could possibly be.

1 Like

Ok.. Thanks for the extra detail.. Re-testing

1 Like

Hi Bryan, I may have screwed something up. The TStat doesn't respond to any commands anymore. It reports any changes I make on the unit itself or if any value changes (temp/hum/cooling, etc) so it's still 'talking' but it doesn't respond to refresh() or any setpoint command. I even yanked it and pulled the battery. Is there a timeout or something that the unit won't accept too many commands within a given amount of time. I've been hitting really hard with commands during debug and now it just ignores everything.
Or could I have turned off remote control somehow?

Not that I am aware of

Any suggestions? It was all working fine other than the scheduler issue, now it doesn't like me at all.

Edit: I excluded/included and it seems to be responding now. So let me know if you find anything with the 'schedule' setting. Thanks.

Hi @bcopeland, I'm sure you're busy but I was wondering if you were able to find anything, or do you need anything more from me, logs, settings, etc? Thanks.

Hi @bcopeland & @bravenel
A little more data, I used RM5 to change the thermostat based on Away/Home and that's been working OK. It's just when the scheduler does it, weird. I don't know what would make it different but the logs were pretty clear.

Please show the setup of you Thermostat Scheduler. Which transition fails with TS?

Hi guys, thanks for taking the time.
I currently have the scheduler removed but it was a very simple setup using modes; Away - set to 76, home - set to 72. The scheduler worked insomuch that it requested the correct temp setpoint when the status was 'away' but it was never accepted/acknowledged by the tstat. When using the scheduler's hold temp feature, the dashboard or the device page it worked fine, the setpoint was requested and the it was immediately acknowledged. But when the scheduler tried, it requested the setpoint but it was ignored. All the minutia details and log screen captures are in posts 5 & 6 above. I could see once in a blue moon that the message might not have made it due to ZW anomalies but it was repeatable... it worked all the time except for when the scheduler did it due to a mode change.
If you can't find anything obvious then I'll be happy to load it up again, setup the scenario, and test to provide logs. Just lemme know.

Download the Hubitat app