Switch Binding Incorrectly Setting Dimmer Levels

The setup I am troubleshooting is a Dimmer -> Switch Binding -> Group 2.1 -> 4 bulbs. From the logs it seems as if Group 2.1 gets "confused" and can fail to tell the bulbs to set themselves to the correct level.

You haven't shown any meaningful evidence that Group 2.1 has anything to do with this issue.

Whoops. I attached the wrong image of the logs. I'm new to Hubitat, but these logs seem to imply that the Switch Binding (app 17) was set to 100%, it set the group (dev 42) to 100%, but the groups lights were not set to 100%.

It is possible that this is a device issue with the way your group is setup. If these are all zigbee bulbs, you can uncheck mixed devices and metering. I don’t know for sure, but I would imagine that Zigbee group messaging and metering are not compatible with each other since zgm is one command to control the entire group, whereas metering would space out commands to each device with a delay.
What actual device is this and what driver are you using? The Advanced Zigbee drivers are the fastest and have the least overhead, but I had to play with the settings to get them to work reliably with Sengled. The older Osram bulbs only seem to work well with the Generic Zigbee drivers, and the Sylvania/Ledvance bulbs work best with the Advanced Zigbee drivers.

The group consists of 4 Segled bulbs. Two are me Sengled Element Color Plus and the other two are just Engle’s Elements. I could definitely try the driver you mentioned. Are their any settings that you would recommend?

This is how mine are set up:




I only had trouble with them if I left a setting unselected in the driver. Click through every setting and hit save and then configure. Just use the rgbw for the color bulbs and the bulb driver for the dimmable bulbs.

Thanks! Let me give that a shot!

Download the Hubitat app