Swap Apps Device bug

I replaced a Zooz 4-in-1 Sensor ZSE40 that kept draining batteries with a ThirdReality Zigbee motion sensor today. (I don't need the extra functions that the Zooz had). Apparently when I used the Swap Apps Device utility, it not only changed the devices in the apps, but it also tried to copy the Current States. I have a screen shot showing the states. The device is a Generic Motion sensor (no temp) but the states from the Zooz still show up.

I tried refresh and configuration buttons, but no help.

Change it to a "Device"; click on "Delete All Current States"; change it back to the correct driver; then hit "Configure"


That fixed it. Thanks for your quick response.

I'm attempting to replace a v4 Smartthings multisensor with a new v5 unit. I've done the Swap Apps Device and switched to Device and deleted state. The new device reports temperature and acceleration updates but does not report contact closure changes. If I use Swap Apps Device and swap back again, the device reports everything properly. Any ideas?

Hit Configure on the device page.

Thanks for the suggestion. Didn't work.

I guess this doesn't always or often work. The failure is a subtle malfunction. I guess I'm going to have to do the replacement manually :tired_face:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.