Support for Orvibo (Living Wise) dimmers?

Found some inexpensive dimmers from Living Wise (also go under the Orvibo brand).

I bought a switch and dimmer to test.

They claim to have the HA profile. I added the switch, it added as a generic device but I was still able to control it's on / off behavior.

The dimmer added as well but I don't have any control of it. Just wondering if someone has these on their system and working under a different dimmer brand?

I didn't see them listed so that's why I was curious and they were cheap so I didn't have much to lose anyways.

Try changing the driver for the dimmer to the Generic Zigbee Dimmer driver. It most likely joined as "Device" if the footprint wasn't known to Hubitat. After you change the driver, make sure you save and then hit the "Configure" button. After that, see if you have dimming control of the device.

According to what I could find, these are ZHA unless the're totally wacky, that driver should work. But only testing will tell you for sure.

Did that but it's like it won't talk to it at all, unless I got a dud unit
Anything glaring you can see missing? I shouldn't have to restart the zigbee server or anything like that correct?

Alarm Triggered? What driver was it set to before? You're sure you hit configure AFTER hitting save on the driver change? Have you tried hitting the paddle on the dimmer? You're sure you have a strong enough signal where the device is installed?

There is no such thing.

Maybe I am doing this incorrectly.

I discover devices, it finds the device and I save it, then after the device shows up in my device list I change the type to Generic Zigbee Dimmer. After that I don't get anywhere. Should I be saving the device type BEFORE I get out of the discovery page or does it not matter?

I did hit configure as well. The dimmer is about 4 feet from the hub testing in my basement.

Okay...what driver did it use BEFORE you changed to the Zigbee Generic Dimmer driver? Was it set to "Device"? If so, you should see a big change on the edit device page. No commands would have been listed before.

Also, once you make that change, you can open live logging in another tab. That will help figure out what is going on?

Thanks for the help Ryan780.

Found out the unit wasn't ID properly with the HUB. I tried doing discovery again and did the factory reset during this time and it grabbed all the info in the field like MFG etc, before it was only pulling zigbee ID and device ID etc.

I think it was grabbing the commands from one of the buttons as I was pressing it instead

works now

1 Like

What driver is it using?

generic zigbee dimmer


YAY!!! Glad you got it working! :slight_smile:

1 Like

I have a number of the Orvibo products: dimmer, switch, outlet.
From LivingWise.
The only issue that I've had with them is that I believe that they will fall off the zigbee mesh if the power is cut to them.
So, beware.
If you have your power cut, check these devices to ensure that they are still active.