Suggestions for simple, efficient way to set a Ge Enbrighten inwall switch to On after Hub reboot

I do a no-no - I have a smart switch that runs to a smart bulb. When you stop laughing -

If I reboot my hub the switch defaults to Off. This in turn makes the ceiling bulb fail for activity reports and a few other things. Normally, the wall switch is left on and all automation is to the bulb and works well.
The enbrighten switch driver has no default setting on initialize - at least none I'm aware of. Is there a physical trick to setting it to always start up as 'on'? What about a boot rule, does anyone just do that? Can you screen cap your method?

Sounds like the thing you need to determine,... Is the hub reboot....

1 Like

yea. I was already thinking of that - using bearmays info gave me:
(but isn't this a bit of a big hammer? )

Is this zigbee?
I have late model Z-Wave Enbrighten switches and they don't behave that way.
They remember last state.

yes. the zigbee ge/jasco 43080's .

You can use the following trigger for your rule:

Location event: systemStart


and THATS why there's a community! wickedly effective and efficient!


Clever solution for sure, but why would this be necessary? How would any switches get turned off because of a reboot? It's not like the hub is sending "Hey, I'm awake, you stay on now, you hear!" messages. Just really curious about this behavior and want to know how/why this would be the case.

1 Like

beats me.. prolly something to do with 'initialize' on devices on reboot.