Suddenly lost an ability to Export/Clone the RM Rules


In a process of cleaning and modifying RM Rules suddenly I lost an ability to
Export/Clone ANY of the existing RM Rules. Clicking on an Export/Import/Clone GUI Button
produces Unexpected Error message:

I was using Export and Clone rules functions before modifying the existing rule(s).

Local Backup-SoftReset-Restore as well as few hub reboots did not fix the problem.
Other than this sudden failure hub and RM Rules seems to be still functional.

Something really bad happened to the data base (I hope only data base became
badly corrupted).

Please advice how to fix this problem?
Should I try CloudBackup-SoftReset-CloudRestore?

Restoring hub to overnight automatic backup fixed the problem.
But I lost all my nice changes I made to the multiple rules.

While I can't speak to what could have caused this, there should be an easy fix:

  1. Navigate to Apps
  2. Find Import/Export/Clone in the apps list
  3. Select the "app status" (gear) icon next to the app
  4. Use the Remove button on the app status page to remove the Import/Export/Clone app, then try cloning your rule again.

Going back to possible causes: opening an import/export/clone in multiple tabs/windows at the same time could cause problems, though I'm not sure if this specific problem is one. It's possible there is some other bug that got you here. Bruce may be able to figure out more from the internal app data if you care to keep that (or he wants to look--the above is an easy workaround).

In any case, this is almost certainly not the result of database corruption, so a restore is unlikely to help (unless it's to a database from before the Import/Export/Clone utility was put into this state, though it's certainly not the simplest approach to solving this problem...).

1 Like

I think, I found what happened:

Now my question is how to fix the described problem?

As I mentioned in that thread, I do not believe your problems are related.

There is no Import/Export/Clone app in the app list.
There is a Import/Export/Clone button if I open whatever app and click on Gear button in the upper right corner.
What I am missing here?

Normally this would be the case if you got stuck in the middle of an Export/Import/Clone (check again if you used the name I provided above and only looked alphabetically--I typed it wrong from memory), but there is another way: when you have the Export/Import/Clone utility (app) open, take a look at the URL. It will be something like:


The 123 here is the app ID, which you can get from your particular URL. Re-format that URL like this instead:


(i.e., replace configure with status and take out everything after the app ID)

Then, proceed with the last step from above: hit the Remove Export/Import/Clone button (in the bottom right) and try again.

Now I know exactly what kills Export/Import/Clone utility.
This is an attempt to Export or Clone paused rm rule.
If rule is paused clicking on Gear -> Export/Import/Clone brings up incorrect GUI.



There is no Download ... button on a right side. Instead there is a prompt for the file name.

Now clicking on anything on the page with INCORRECT GUI immediately and instantly
kills Export/Import/Clone utility. The page with incorrect GUI must be immediately left.

I just tested and was able to clone a paused rule without problem. For the most part, a clone (and export) just copies internal app data to the new app, so I can't imagine this would matter much anyway, but here's one guess: do you have any unusual characters in the app/rule name? I just tried some unusual things and wasn't able to break it no matter what I did, FWIW.

Also, have you tried the above, and are you still able to re-create the problem after doing so?

Can confirm that attempting to Export a paused but otherwise empty rule named "_Test Clone Paused Rule" immediately breaks the Export/Clone app. The error thrown in Logs is:

What you see in the app at the time it breaks (after having clicked Gear > Export > (asks for filename) > then clicked Clone (select rulename) instead) is:

As recommended earlier, doing a Remove Export/Clone, unpausing the rule, and retrying Gear > Export on same test rule proceeds normally. Repeating test suite with rule named "Clone Paused Rule" (i.e. omitting underscore from original name) ran into same issue, narrowing down the cause to "Pause" as the likely culprit.

That I can sort of replicate, except I again find no correlation to the rule being paused or not. You can avoid this by clicking either "Export" or "Clone," rather than starting an export and then trying a clone, as it seems you are doing. If you are stuck on this screen:

or this one:

then you have started an export.

The problem I'm finding is that "Cancel" here does nothing (nor does downloading the file, though I'm not sure if this was ever supposed to take you back to the main page or not). The workaround is to hit Done, then start an Export/Import/Clone again if you either want to do both or changed your mind. Indeed, hitting "Clone" while in this state will throw an error (but I am not able to replicate that error from the get-go -- only if I get here first). If you got stuck in this state, removing the Export/Import/Clone utility using its App Status page should also work.

Because your exact steps to replication are not clear, or at least a mere paused rule does not do this for me, there could be something else for you. But this is all I can find for me -- Cancel does nothing, and if you got stuck in a state like either shown above, hitting Clone throws an error.

Tagging @bravenel to see if he can figure anything out from that or maybe sees something that is different for you.

1 Like

Unquestionably, as you point out, the problem crops up upon user clicking improper sequence of buttons in Export/Clone app. Normally, having clicked EXPORT would "disable" the CLONE button (though still present in the UI and clickable). Somehow, in this edge case, for a Paused rule, that same sequence leads to bad things.

If I hit DONE at least in my specific case the disaster is 100% guarantied.

1 Like

I'm again unable to replicate that, but if that doesn't work, removing the app (as "Done"-ing your way out normally would do this, too--this app is only "installed" when it's actually being used, normally) would also work around the issue.

1 Like

I am not really surprised because every system configuration is very unique.
And BTW, I am unable to follow yours instruction how to delete this Export/Import/Clone
application (if this is an application?). This one is not listed neither under Apps tab nor
in the list of "Add Built-in App". When I am on the App page the URL is:
http://IP_Addr/installedapp/configure/2554/main after modifying URL to:
http://IP_Addr/installedapp/status/2554 I can see a Remove Export/Import/Clone red button.
But frankly I am afraid to click this button because it is not clear how to re-install it back.
This is my work horse hub. During past couple days I already had more than enough problems.

Clicking that red button is precisely what you need to do for the E/I/C app instance to be removed. Trust us, it will return when summoned next time.

As explained above, the E/I/C app is ephemeral by design; it will only ever appear under Apps if you invoked it but didn't complete an Export or Clone operation.

For now I know very well what must not be done.
But anyway Thank You for the tip.

1 Like

So all of the errors you kept posting were after your initial error, not new ones you were able to re-create after trying the suggestion provided to you of removing the app? That could explain why I was not able to replicate your problems.

(As mentioned above, there is no need to fear removing this app; that's exactly what it does to itself when you're done. It's just a front-end to the feature, not normally visible.)

I suspect you did not see the second set of instructions after you noted this the first time:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.