Stuck at verifying download. brand new hub unboxed today

unboxed my new hub. followed the setup and enrolled four zigbee devices. The sengled strip was not a discovered device type so controls were not available after discovery. Decided to get the latest hub firmware before troubleshooting further.

  1. Selected settings>check for updates and found available to replace existing

  2. kicked off the upgrade

  3. progress indicator moved consistently up to 30% and then moved to verifying download

  4. currently sitting at verifying download for 30min

This seems to be a completely automated process with no opportunity for a user to perform any troubleshooting. I attempted on my subtended DDWRT router running my AWS openVPN WAN tunnel and then moved to direct connect on my main vanilla ISP router with the exact same results.

Is this a typical hubitat trouble with a know workaround or am I trailblazing through a corner case bug in the upgrade automation?

I was really looking forward to playing with my new toys on a rainy day and getting my 14 year old son interested in some simple coding logic for the new game room lights. :cry:

Welcome to the community.. Sorry to hear that you are having trouble right out of the gate.. But support seems pretty responsive to problems like these.. Tagging @bobbyD he does great work...

1 Like

Since it't the weekend, they may have others tending to tickets as well. Please send an email to to get someone on your problem. I'd also post something on the facebook page in case @bravenel checks there. I had trouble getting up and going when I got mine. They fixed it quickly. Like 5 minutes, done.


I found the generic zigbee RGBW driver for the light strip so the software upgrade trouble is not holding me back at the moment. I will let them respond when they get time or email Monday if I do not get a response to this support thread. I am watching new user videos about dashboard operation. Glad to see the community is active and helpful. Thanks!


The community is very active here.. I think you will like it here..

1 Like

When you first booted up your hub, it did not automatically update to the latest firmware? As i understand the process, after registering the hub, it should go out and update itself to the latest firmware. Your hub had firmware from October? I thought there was a much longer lead-time for hubs to be manufactured and distributed. I wouldn't think it would be that short.

Is the hub still sitting at Verifying Dowload? Or have you pulled power and tried rebooting it? If it truly didn't finish downloading the updated firmware, then it should boot on the old firmware. You only get into real trouble when you interrupt it when it's installing the firmware. But in either case, try to navigate to the hub's ip on port 8081 and report if the page loads.

Welcome aboard and sorry for the troubles. This is not common, but it has happened before when jumping over a few versions, to the latest version, as it is in your case.

If you are still stuck on verifying download, a reboot from "Settings" page might resolve the problem. If that doesn't work, I would try to reboot from the Diagnostic Tool (yourHubIP:8081 - replace yourHubIP with actual IP address of your hub).

If all fail, then I would try a Soft Reset by following instructions in below document:



Do you ever take time off for yourself?!!


Seems he takes the 2am to 4am part of the day for himself.. 90% of the time. j/k :slight_smile:


It doesn’t appear so.. I feel sorry for the guy.. He is always responding...

1 Like

I just registered a new hub (C5) yesterday and you will have the option to update the firmware. It's not automatic. My hub was also at before I updated it. No problem at my end whatsoever though.

Edit : took about 35 mins from download to finish.


Bobby explained it to me...there was a change to the initial setup and registering process not too long ago. My info was out-of-date.

1 Like

I am not sure. Possible because I am not a new user? This is my 3rd hub.

What? What aren't you sure about? I'm not following you.

I believe there may be a team all using the same account. Bobby and bravenel seem to be everywhere and at all times!

1 Like

I wasn't sure the hub discovery steps for existing and new user are the same. I didn't have to do much. Login to my portal, click on the new hub and add the name of the location to the hub.

1 Like

When you're setting up a new hub, it doesn't know whether you're an existing user or not so how could that make a difference? It hasn't connected to anything yet.

That IS the expected experience of new users :slight_smile: Anything less than that, is an unfortunate event.


Is just proof that my phone's notification works as expected. The day you don't see us responding, is the day you know our phones stopped working properly.