Stubborn ghost that i have exhausted my experience on

I had a device that was giving me problems.

When I excluded it, HE said “unknown zwave device removed” rather than calling it out by its name. I have never seen this before.

The device was still listed afterwards in the device list so I tried to remove, then went to force remove when that failed.

After force remove the device was removed from the device list, but it is showing up as a ghost in zwave details.

I have rebooted, shut down, tried many times to hit the remove button yet it wont go away.

When I log in via Silicon Graphics / Zwave stick, it does not show a device 91.

Zwave repair does not find a device 91 either.

The error log when i hit remove says " Failed node 91 remove status: no reply". i have run remove countless times (20+) with no removal.

My network as you would expect is behaving unpredictably now.

I appreciate any advice – thank you.

Calling in the cops... @bcopeland, @bertabcd1234, @bobbyD, any ideas?

The device not showing up in PC Controller but showing up on the hub Z-Wave details list is new to me, as far as I can remember.

Sometimes the "update" gets stuck with PC controller. Have you excluded and re-paired the PC controller stick (as secondary controller) to make sure it gets the full network details?

yes - twice, thank you for the reply jj

I know it's not fun, but I would wait a day or two and see if removal works then. Z-Wave can require patience. In the meantime, you might want to try shutting down, removing power for at least 30 seconds or so, then reconnecting power to reboot the hub (i.e., don't just shut down or reboot--this intermediate power removal is the only way to fully reboot the Z-Wave radio). That may make other things work normally again, at least.

I'm not sure what would have made this go wrong in the first place, though. It sounds like the device didn't have the same node ID as you thought it did on the hub, perhaps because it was re-included under a new node ID or included on a different hub/controller somehow, any of which you would had to have done manually and probably remembered. [EDIT: The guess below about hex vs. decimal is a good thing to check, too!] A "Force Remove" will indeed leave behind the node in Z-Wave Details if it's still there, so that part isn't surprising.

Are you aware that the hub typically refers to the devices in hex and PC controller uses decimal for the node IDs? So it might be 145 in PC Controller.

1 Like

thanks - yes i have been working / waiting on this since 9-8 hoping it would heal itself. When i shut down i did remove power, 3 times, each time waiting 2-3 minutes before reconnecting power.

yes - it is device 91 hex, and PC Controller does not see it. I have excluded and re-paired PC controller twice and no changes.

My A.D.D. / IQ test failed - you were dead on with respect to PC Controller using decimal 145 not 91, i used PC Controller to remove device 145, she is gone now in HE! Thank you so much for you help all - what little hair i have left i wanted to keep. Awesome community support, again thank you j

4 Likes

PC Controller downloads the device table from the hub when you pair it, so it should definitely be there if the hub is seeing it. All other devices are listed fine? If you have a lot of devices it might take a bit for it to get the full list from the hub. Only thing I could think of is if the zwave table is corrupted.

Also, unless the device says "Discover" by it on the hub, it really should not be hurting much. The hub wont be looking for it actively and after a day or two the other devices will find better routes. Eventually it will have 0 neighbors and nothing will try to talk to it.. I have 2-3 devices right now which are paired and powered off, which would basically create the same "ghost" state. Does not seem to be causing any issues.

1 Like

I was sure that was it! I was pretty close to asking for screen shots to prove it was 91 on the hub and 145 was not in PC controller.

2 Likes

I am going to name my next six kids after you! i really appreciate the help, jj

Download the Hubitat app