Strange shut downs and hub behavior

Just recently I have experienced some strange hub behavior not seen before. Has anyone seen this? I've not otherwise made any changes to my setup.

  1. I noticed one day that the hub had just shut down. There was no power failure or fluctuation. It was just off showing the red light on the unit. I had to unplug and replug it to reboot.

  2. Just yesterday I tried to pull up a dashboard and it was supper supper slow. When it did come up all the text and icons were messed up. It was very difficult to get any response from the hub and had to restart it.

Not typical behavior of a hub and I haven't seen anybody report anything similar in the last little while to suggest any change in firmware did it.

Anything in the logs? Apps, bad devices, bad drivers, etc. can bring hubs down if the problem doesn't correct or loops and and the long running action blocks other actions until everything is waiting and the system runs out of resources and crashes.

Give the logs a look to see if there is still something from those events. If not and it continues to happen you may start to selectively disable apps and/or devices until you find something that is causing it.

1 Like

Any changes to hub location or other devices around it that might be adding to the surrounding temperature and causing overheating?

1 Like

Thanks for the reply @codahq. I did not notice anything in the logs nor have I changed anything in a little while. I also don't have that many apps or devices or rules. It has not happened again but I have also started seeing some general slow downs where rules are taking a lot longer to execute and some devices don't seem to respond to the rule. Those devices do respond to manual changes just fine. I have tried manually triggering the rules and can get mixed results. I've repaired z-wave a couple of times and that seemed to fix the issue each time, but it keeps coming back after a period of time. I only have a few rules and they are not complex.

Thanks for the suggestion @SmartHomePrimer. The hub is located on an open shelf where it's always been with no other new devices. I will however keep an eye on that. Thanks!

1 Like

I wanted to add that this has happened again in the last couple of days where the hub has crashed. I looked at the logs as soon as it started up again and I didn't see anything out of the ordinary.

Have you sent in a support ticket? I think it's time


Next on my list.

Before that do a soft reset. The issues you describe are very reminiscent of database corruption.

1 Like

Thanks. Didn't realize that existed. Will give it a go.

1 Like

The description is a little confusing. I see that all the devices with stay connected after doing this so when I restore from my backup everything should be as it was? I won't have to recreate anything?

Also, if I am restoring a backup would I not just be restoring what was corrupt?

That's correct (if you follow the procedure as outlined in that link from the Hubitat documentation).

Databases are cleaned up before backup.

Awesome. Thanks for the reassurance and the quick reply too!

Just remember. When this screen comes up:

Choose Restore from Backup that is in small print at the bottom!

1 Like

Already done and back up and running! We will see if this solves my issue. Thank you for caring enough to follow up with this info.


Awh @aaiyar you care.
@aaiyar is the bombdiggity in my books.


The update on this is that the soft reset seemed to work quite well until yesterday morning when I woke up to find the hub unresponsive. I had to pull the plug on it to restart. I couldn't determine anything from the logs either. Everything seemed normal with no warnings and it stopped in a different place than before. I guess it's time to file a support ticket.

Have programmed any reboots?
I do reboots twice a week on both my hubs at 1.30 am and keeps things going.
There some apps out there you can use.
I'll attach if you want to have a look at them.
One is called Rootin' Tootin' Self-Rebootin by @adamkempenich and the other is called Rebooter by @dman2306.
These may help you keep things running for you.

Thanks @bobbles. That's been something on my mind. It might be necessary if I can't otherwise sort this out. Appreciate the references. This saves me the research time to find these option.

Thank you!

No problem. It's mitigation not a solution I'm afraid.
Hopefully we get a solution soon. I not a techie but problems like this seem to be difficult to track but sure the HE guys are looking into it.