STELPRO wave plus thermostat-line level show no temperature controls

I am moving fom my 2 veraplus controllers to Hubitat. I have just 1 snag. I have 3 Stelpro STZW402+ thermostats. And I don't seem to find a temperature control button when I add the thermostat to a tile on my dashboard. Any ideas?

It may be that the mode is “off”? Here is an example where one of mine doesn’t show the control and the other does. If I change the one that doesn’t to “Heat”, the controls should show.

Thanks for your reply.
Click "unknown mode" results in nothing. This thermostat is for heat only; a baseboard heater. I have a working tile for my Honeywell T6 thermostat. This thermostat worked well with my VeraPlus controller.

I know some programming languages. But I don't know where to start on the Hubitat.
I had hoped a generic zwave thermostat driver would work for it.

Screenshot 2022-12-17 at 7.25.15 PM|690x476

P.S. I tried to send the screenshot but was told I "could not embed media items in a post".