Status tile for an Aeon Labs DSC06106-ZWUS

I successfully paired an Aeon Labs DSC06106-ZWUS smart switch into Hubitat. I can turn the device on and off from the Commands buttons on the device menu, but I cannot get the tile to show state of device. And, I am only able to turn off the device from the dashboard tile (which continues to show "sending"), but not back on.

It seems that there must be some trick to get the dashboard tile to match the actual state of the device, but I don't find any hint in the documentation or Community.

Any hints on where to look?

Does state match the device actual status on the Device settings page and change quickly? What about if you press the physical switch vs using the Device settings page?

This is very common symptom of a weak mesh. You probably have a weak signal to this device. Too far away from a repeater, "shielded" by something, not enough repeating devices in your mesh, or just a poor mesh in general.


Thanks for quick response. While I suspect that my mesh is a little messed up as I transition from devices on Vera to Hubitat, I don't quite follow why the Command buttons on the device settings page quickly and reliably control the switch, but the Current States indication just to the right of the Command buttons for the switch always shows off, as does the tile on the dashboard. Might there be something in the "driver" that isn't connecting the current state with the actual setting of the switch? As I understand Hubitat, I should be able to click on the dashboard icon and turn the switch on and off, right?

Just discovered that if I Poll the device from the Command menu, the Current state of the switch and the dashboard tile transition to the correct switch state. So, it seems that the switch isn't sending back it's current state to the controller. Perhaps this is characteristic of early Z-wave devices without the "Plus" moniker?

Hey, did you get anywhere with this? I have switched from Vera to Hubitat and experiencing the same issues with this one switch. I've tried a few built in drivers as well as the one made by bcopeland without any luck!


I'm not sure what was going on in my early experiences with Hubitat and the mesh that it created. Things seem to have stabilized over the past two months with these Aeon switches and I can now turn the switches on and off from the dashboard pretty reliably. Although the non-Plus Z-wave devices apparently don't automatically report back their status, I think the drivers have been tweaked to poll them after a commanded action to effect the same result.

Am still struggling occasionally with Hubitat and learning its quirks, but with each update it seems to be getting more predictable. Overall, I'm having much better luck than with Vera/Ezlo. That said, I am still unable to get the early Aeon door and window sensors (non-Plus) devices to include with my hub. However, the newer Plus door and window sensors seem to work pretty well. Live and learn, and move on from purchasing any more non-Plus devices.

Ya, i hear you.. this seems to be about the last one causing issues. I'm trying the Zooz Power Switch driver and it works pretty well (i think) except for not reporting a status change when the switch is manually pressed. Guess I'll have to wait and see!