Speech volume on Fire Tablet

This isn’t necessarily a Hubitat issue, rather a Fire Tablet issue, but I’m hoping someone in the community might be able to help!

I started using Rule Machine to provide speech functions (instead of EchoSpeaks) such as “ back door is open” when the door contact sensor is open. Hubitat “speaks” simultaneously on multiple devices throughout the house, including a few Echo devices and a Fire Tablet, which is the home ‘kiosk’ running dashboards on Fully Kiosk Browser. Because the different speakers have varying loudness, I want the volume to be the default per device, rather than setting a specific percentage in the rule.

The problem I’m having is that something is causing the Fire Tablet to revert back to an inaudible volume level (like 15%) on a daily basis. It is in a flush wall mount, so the volume buttons are inaccessible. I have to remove it from the mount, or re-adjust the media volume in settings. Any idea what could be adjusting the volume level, or how to keep it at 100% all the time? Fully is the only thing running on the tablet, which is stock Fire OS.

I have two Fire HD8s with Fully and never encountered the hardware changing it's own volume. What I did experience is the FKBC device app resetting the device's volume setting to 50% when the HE box reboots. I fixed this with the following RM. It also reloads the startUrl at reboot because the dashboard would occassionally not update after a reboot. (YMMV)

Didn’t think about a separate rule to reset the volume - thanks for the tip!

Wanted to let you know, I set a rule to bump the volume to 100% every morning, and this seems to have solved the problem. Thanks again @arnb !

1 Like

Download the Hubitat app