Sonos Errors on latest?

Since upgrading to the latest ( ), one of my Sonos speakers keeps giving the following errors in my logs:

This particular speaker is a Sonos Beam, but it was fine before and I have another which is working fine connected to HE.

Anyone else seeing that error?

The speaker works fine and is getting events in HE, I'm just getting these errors every day.

1 Like

Got the same error again this morning, but for a different speaker.

Still getting these for one speaker, and i have no idea why... hmm

You are not alone, I've seen this recently too.

@SoundersDude I tried go into the hubitat Sonos app and choosing to re-discover devices, then exiting it. Then going to each device and selecting save device. I haven't had the error again in the last 12 hours, will report back if I see it again though.

On a side note, though, you mentioned you are currently on *.137 firmware, the current firmware is no *.140 so you might want to update as I believe there were some changes which applied to Sonos in one of the most recent hot-fixes.

Yeah, I'm on now and am still seeing that error, sorry, never updated the OP.
Hmm, I'll try that Just did a "save device" on each one and will see over the next 24hours, thanks for the suggestion.

Update that didn't do it. Still got an error on one speaker.
Tonight I'll turn on debug logging to see if I can see a relevant event that is triggering this error.
So frustrating.

Sorry to hear that @mike.maxwell would likely be the best person to shed some light on this issue.

1 Like

which model is generating this error?

I see this most consistently (one or two errors overnight) on my Sonos Beam (first year it was released).
Per a few posts up, I've also seen this on my Sonos Connect Amp a few time, It's the last models/most recent of the original amp (white) that is compatible with S2, not the brand new "Amp" upgrades they now have with the airplay.

Happy to get more details if anything is helpful. Right now I'm not seeing any specific "bad" behavior from my speakers, just concerning I'm getting this nullpointer error and have no idea why.

Other speakers I have which so far seem fine unless I missed the errors (I don't check every day):

  • 2nd Sonos Beam (2 years newer)
  • Sonos One
  • Sonos One SL
  • Sonos Move

I saw the error on a couple of my Sonos Play:1, it just started happening recently.

currently I have a play, play one, a 5 and a connect online, and of course I'm not seeing any errors, but that's typical right?
I'll add a debug line where I think the issue is, maybe we're getting a call to the driver and the entire payload is null or something...

1 Like

:wink: Of course, why would life make that easier for us? lol

Thank you! Also if there is anything you'd like me to do to help narrow down, I'm more than happy to!

Especially when the error is so random, I'm using my Sonos exclusively for TTS mostly with the notifications app and rule machine.

If it helps, I have an amp and a move and I am not seeing this error. I am not using TTS with either.

I don't think it has anything to do with the specific sonos type.