Sonos always says "playing" when grouped, with no Play/Pause control via HE

My Sonos device control does not seem to work anymore, if the device is in a Sonos group.

If I move the Sonos device out of a group (in the Sonos app), so it is by itself, I can control volume/play/pause/etc via HE. But if that device is in a Sonos "group" it will not respond to HE, and always shows "playing" even if the group is paused. This is new, it use to work fine.

I have been controlling the "group" by sending play/pause to one device (kitchen), but now it does not work unless 'kitchen' is alone. If I send a "speak" command it will kick the unit out of the group to speak.

Log files show the same results. When stand alone it reports playing/paused/volume. As soon as I add it to a group it changes to playing (even if the track is paused), and stays 'playing' with no updates on volume, track changes, or pausing.

I have tested the actions on multiple Sonos units and they all act the same.

I have already tried remove the Sonos app and reinstalling, no effect.

Anyone else having the issue, is there a fix?

When playing anything to a sonos group, I only ever include the group 'master' in apps etc.
This seems to work well for me.
The only thing that doesn't is the volume for the 'slave' devices (that's why I added it separately in Message Central)


As always thank you for the quick, concise, and correct answer.

Kitchen is usually the "master". I guess when I kicked it out playing with "speech" it made someone else the master. Another reason to keep speech of Sonos :wink:

I blew up the group and re-did and now it works like before.

Cheers :beers:

EDIT: Gonna check out Message Central too

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.