Sonoff S40 outlets

I've read that people had no issue connecting Sonoff S40's to hubitat, using the generic driver. I can't seem to get any of them to connect. But I can't seem to get anything to connect to hubitat that I thought would be able to. I may need some hand holding, although these seem fairly simple to connect, from what I have read. I'm not sure what I'm doing wrong.

I have two of them, paired right up no problem. Go to Devices > Add device > Zigbee > Start Pairing.
Wait a few seconds then put the device into pairing mode (I forget how, its in the instructions).

Also, are you SURE they are Zigbee, and not Wifi or Bluetooth?

Sorry one other thing, were these paired to another hub prior or are they new?

I'm stupid....I went to Find by Device type>outlet>generic.....instead of zigbee...thank you for that.

1 Like

Figured it was something simple like that :wink:

Wait...still not working. They are zigbee...I bought them mostly for the repeat purposes. I see a Sonoff driver under Device types>Outlets>Generic and I select add, and then Zigbee. Thats what I have been trying. I tried going straight to add zigbee as well...doesn't seem to make the connection still.

Whats the difference between going Device types>outlet>Sonoffs (or generic)>add zigbee and going straight to Add zigbee from the device home page. Do they need to be right next to the hub? Is 5 or 6 feet away ok?

Probably no difference except it might give you more instructions, or possibly pick the right driver more reliably. Going straight to Zigbee it will try to pick the correct driver if Hubitat has it set, otherwise you can change the driver after it pairs up anyway.

5-6ft is plenty close, I have paired them much further away.

Does it flash slowly when you plug it in? If not you might need to factory reset it, which I having a hard time finding that online. The PDF instructions I found dont tell you how.

It seems like most of the Sonoff stuff you hold down the button until it starts flashing to factory reset it, 10-15 seconds maybe?

They do blink slowly when I plug them in. it says that should stop after 3 minutes, but it never stops. Is hubitat susceptible to interference from other electronics (nvidia shield tv, TV, Receiver). I have 8 of the Sonoffs (bought more than enough for a mesh I was hoping)...I've tried a few of them already. No joy. I have an eero mesh set up. Could that be causing me an issue some how?

If your 2.4Ghz band is oversaturated it could cause problems. I am in a typical residential "suburb" neighborhood and that band is not bad here. When I was in an apartment the 2.4ghz was so bogged down I could barley get Wifi 2 rooms over.

Try going to settings > zigbee details
Make sure the Radio is online, and also try changing the channel to 25 (I think I read somewhere that one would have the least overlap with Wifi).

I've also tried some Aqara pieces...zigbee motion sensor and such. I couldn't connect with hubitat and I ended up using the Aqara app and connecting with Alexa. I don't think I've been able to connect any zigbee devices with this hub. Although much of them were recovered from the house I bought...so I wasn't sure if they should work orr not. I connected them through eero and alexa, but not through hubitat. I must be doing something wrong, although these seemed simple to get working when I researched the community. Like you said, the connect right away for other. I changed the zigbee channel to 25, and tried again. No joy.

When I try to change the channel to 25, it acts lie it's doing it, but then it reverts back to 11. The zigbee radio does appear to be on, but does not show any logs....and it show no zigbee devices attached at the bottom. I think there is something not set up correctly in my hub. I'm just not surre what that would be.

When I installed the Hubitat, was there anything I should have done or needed to do to start attaching zigbee device? It doesn't seem to be connecting with zigbee. It has found my phillips hue and all of those lites, and I got it connected to my blink camera system...but zigbee devices including these, Aqara, Eria and others I have not been able to connect via zigbee.

If nothing is connected to the zigbee radio yet you could try resetting it.
Also do a full power down, unplug for 10 seconds, and boot back up. That will reboot the radios.

I went and looked at the log. As you can see, it seems like it only searches for the zigbee device for miliseconds, and then stops. Here is a few of my last tries:

sys:12022-09-14 07:09:08.140 pm Zigbee Discovery Stopped

sys:12022-09-14 07:08:08.134 pm Zigbee Discovery Running

sys:12022-09-14 07:07:14.313 pm Zigbee Discovery Stopped

sys:12022-09-14 07:06:14.312 pm Zigbee Discovery Running

sys:12022-09-14 07:00:41.433 pm Zigbee Discovery Stopped

sys:12022-09-14 06:59:41.427 pm Zigbee Discovery Running

sys:12022-09-14 06:59:04.113 pm Zigbee Discovery Stopped

sys:12022-09-14 06:58:18.113 pm Zigbee Discovery Running

sys:12022-09-14 06:58:18.110 pm Zigbee Discovery Stopped

sys:12022-09-14 06:58:04.118 pm Zigbee Discovery Running

I did the reset. I'll try unplugging for a bit.

Unplugging it did the trick. When I brought it back up, some items in the zigbee radio had changes...specifically the ID number changes. It found my device pretty quickly when I searched. Thank you very much for helping me figure this out. Finally...I've connected a zigbee device! Finally! Thank you!

Just following up on this one. I did get all of the Sonoff outlets found and added. But something doesn't seem quite right. When I go in and look at the commands, should I have a button to turn them on, and one to turn them off. It seems like I am missing commands. I have a few like Configure, and Remove child (or something like that), and Get information...but it seems like I should have an on/off comand. Where you choose Device, with the drop down list, I don't see Sonoff outles. A few other Sonoff devices, b

The S40's are WiFi.

SONOFF S40 WiFi Smart Plug with Energy Monitoring, 15A Smart Outlet Socket ETL Certified, Work with Alexa & Google Home Assistant, IFTTT Supporting, 2.4 Ghz Wi-Fi Only 4-Pack

No they are zigbee. S40 lite There is a wifi version but I needed repeaters so bought the zigbee s40 lite https://www.amazon.com/dp/B09XMH3X3G?psc=1&ref=ppx_yo2ov_dt_b_product_details

1 Like

Download the Hubitat app