Sonoff S26R2ZB compatibility?

Hello there!

So I rather hastily bought a pack of these babies

Looks like they come in UK and EU flavours and they're super cheap. I see people just buying them to extend the zigbee network, though I am intending to use them as switches.

Anyway, they list Samsung and a bunch for compatibility, not habitat though that's not very surprising. They discover and putting them on Generic Zibgee Switch shows a status, but they don't seem to respond to On and Off :face_with_raised_eyebrow:

Anyone else had luck with these guys?

Did you click Configure after changing drivers to Generic Zigbee Switch?

I did not, good spot. Just tried that now though and it's no better.

The status changes nicely in the UI when I press the little button on the gizmo, but no luck the other way around. :frowning:

Possibly a bit late now that you've already bought the Sonoffs, but the SmartThings UK Socket is recently around £16 on Amazon which is a steal for a great quality socket that also supports power metering.

1 Like

Well that is interesting, I'm certainly not beyond sending them back and getting those. Seems a shame though, so close.

Also, these suckers are £25.65 for 4, that's like £6.50 each! But that's very expensive if they don't work :slight_smile:

could you try another driver? There is some nice Sonoff outlet support in this:
https://raw.githubusercontent.com/markus-li/Hubitat/development/drivers/expanded/zigbee-generic-outlet-expanded.groovy

Thanks for this, what repo does that come from can I ask?

I did try it, I don't this that's any better I'm afraid.

dev:3532021-10-20 18:13:25.455 infoBIND RESPONSE CLUSTER EVENT
dev:3532021-10-20 18:13:25.217 infoINCOMPLETE - DO NOT SUBMIT THIS - TRY AGAIN: fingerprint model:"null", manufacturer:"null", profileId:"C05E", endpointId:"0D", inClusters:"1000", outClusters:"1000"
dev:3532021-10-20 18:13:25.213 traceApplication: null
dev:3532021-10-20 18:13:25.207 infoNOT IMPORTANT: Application ID is missing for the fingerprint, requesting it from the device. If it is a sleepy device you may have to wake it up and run this command again. Run this command again to get the new fingerprint.
dev:3532021-10-20 18:13:25.202 traceModel: null
dev:3532021-10-20 18:13:25.198 traceManufacturer: null
dev:3532021-10-20 18:13:25.195 warnManufacturer name is missing for the fingerprint, requesting it from the device. If it is a sleepy device you may have to wake it up and run this command again. Run this command again to get the new fingerprint.
dev:3532021-10-20 18:13:25.190 debugGetting info for Zigbee device...
dev:3532021-10-20 18:13:23.391 infoSKIPPING ping() since there has been events received during the last 25 minutes...
dev:3532021-10-20 18:13:23.321 infoRecovery feature ENABLED
dev:3532021-10-20 18:13:23.267 infogetDriverVersion() = v1.0.1.1123b
dev:3532021-10-20 18:13:23.228 infoinitialize()

The fingerprint stuff - This great driver queries the device and creates a fingerprint of what the device can do, it originally asked that you send that info to the developer so he could add it to his driver to build a list of sorts. He is no longer directly supporting this driver!
Don't be put off by the log messages, they were there to help during this identification process - the driver will still function - I should have warned you'd see that but to ignore it.
I have some devices that didn't work well with the generic drive and switched to this and it solved me - I was just hoping you might benefit as well. It comes from this Github Repo:

1 Like

Sir! You are a genius!!

I used the generic switch driver from that repo and it worked like a charm!

Thank you for helping me out. Now I think all should buy these for £6.50 a pop and pimp your sockets with this driver :smiley: !

2 Likes

awesome! so... I will note why I'm so aware of that driver. - It has a Presence built in which is totally cool. it will refresh automagically. I myself modified it so it didn't show up as a Presence device when I was building rules. but Yea. Markus is a genius and I'm just plain glad to help someone by pointing it out.

1 Like

Hi, this is also worked for me which is brilliant, but child devices were created for the single socket. Did you get child devices? If i disable the option 'Enable Multi Endpoint Discovery' then the switch stops responding to ON/OFF.
Will having fake Child Devices use up the total Device count?
Thanks

I did get child devices, I was content to leave them. I can't talk to the total device count I'm afraid.

1 Like

Hi @Confused_Penguin I too have some zigbee Sonoff S26 plugs that I want to connect. Although I'm not entirely new to home automation, I'm very new to Hubitat (so far I have only installed natively supported devices) and I would appreciate your guidance with one step of getting this to work.

I've installed the T4HE Tasmota for Hubitat Elevation app and drivers from markus-li, as you recommended. But how do I now add an S26 plug in Hubitat? I have clicked to manually add a device but what should I do to "make sure the device is connected to your wifi"? What do I put for the IP address in the below screen?

Thanks in advance!

The S26 Sonoff Plugs come in WIFI, aka Tasmota (ip needed).
Or S26R2ZB - ZigBee (different DRIVER ) also available on HPM.

2 Likes

Oh, d'oh! I did think it rather bizarre that any zigbee device should be connected to wifi in some way. I was aware Sonoff also make a wifi version of this, but stupidly it never even occurred to me that they would have called both of them S26 – one model just with a suffix! Thanks for the pointer to the other driver :blush:

1 Like

Download the Hubitat app