Somfy ZWave Blinds (Dimmer)

Quick question, as I'm looking at Bali blinds. I see threads here that talk about their Autoview, but Bali makes two kinds of motors - the Autoview (now listed as "Zwave plus") and the "easyview" with Radio Tech Somfy (RTS). Which is the better option for Hubitat integration?

thx! (from, the not-as techno as my hubby wife)...

Go with the z-wave option.

Hubitat can support z-wave, zigbee, telnet and IP-based devices.

I have a Graber blind in my office that uses a Somfy (Z-Wave) module. So far it's working fine. It's been in about a month. Got it at Zebra Blinds.

I tried this driver; while seem to be able to talk to the shade & fetch info just ok, but it is throwing an error when I try to open/close/set position.

I even got hold of the driver code from ST and compared it what @DeveloperDavidB had posted in this thread. Everything checks out - only changes are color and replacing 'physicalgraph' with 'hubitat' (See comparison), so not sure why is it not working for me?

I am really struggling to have my shades work, so any help will be appreciated.

I'm in the same position as @yashvind . None of the driver codes work except the dimmer but I can only put the blinds up or down, they will not accept any position. Any update on a potential solution?

Though not fully resolved yet but I have made some progress. See details on this post. If you want, I can keep you apprised and help with the steps once I achieve full resolution.

1 Like

For anyone looking for a driver that works, I've taken a bit of time and done my own version and it works with all of the Graber roller shades that I have. Those include Bali, Somfy, Springs Window Fashions, and a few other names.

The driver works with Hubitat dashboards, Google Home integration (using community) and I would assume all other integrations. All position sets work as well i.e. setting the blinds to 50% on the dashboard sets them to 50%.

If you are using the Hubitat integration with Google Home and not the community version it will still not work saying open and close. This is not a limitation with the driver, but a limitation with how Hubitat's version of Google Home passes these parameters to Google. There's a number of posts on how to get the community version to correct this.

If anyone has issues with it please let me know.

I'll work on additional features and cleanup when I have time and I'll also work on a driver for the z-wave remote for Bali.

3 Likes

I had some reliability issues. Based on recommendations I reached out to the location of purchase (zebrablinds) and they had a firmware update for my blinds. Working well since.

What’s your firmware version of your blinds?

12.1 ... If I recall correctly

Thanks for this! Finally home and going to give this a shot shortly.

Apologies if this is the wrong thread to post against. I have the same Bali button controller as the OP. My blinds are directly enrolled with Hubitat as is the controller. Alexa, my phone, and the Hubitat control the blinds perfectly. This button enrolled with Hubitat has some issues. Button 2 for close works fine but button 1 for open causes the blind the slow and then stop only 4 inches up. You have to close the blinds and use something other than the button to open them. I’ve just enabled log actions on that app but I’m at a loss to explain this behavior unless it’s a button hardware issue. I’ve ordered a zwave switch from Amazon to see if that fixes this issue. Any thoughts?

Solved: I reset the controller and re-paired it with the hub and it works correctly now.

1 Like

Is there a driver that works with Bali Roller Shades and Shows up in Google Home as a "Shade" instead of a switch? Functionality with the Generic Z Wave Shade driver is fine but hoping the integration works similar to the Bali App Drivers.

Thank you so much for this. The generic driver doesn't support "stop" which is essential, and yours does. It works perfectly. Many thanks for this.

One question - I paired my remote too but would prefer it to be like it was when new with direct pairing to blind. Is there a way to do that without losing my pairing with the hub? If not I suppose I could just write a rule to make it work as desired.

This is because of the Google integration and not the driver. You need to use the community Google integration in order to get it to work properly.

Honestly, I originally thought that I would improve the driver for better support with the remote but I never use the remote, so I never got around to it.

I either use Google Home voice commands, Inovelli Switches, or my Home Assistant dashboard on tablets throughout the house. My family prefers the light switch triple tap or voice commands.

Got it. I ended up writing a rule to make the remote work. I also wrote a double-tap rule for my Innoveli switch. I ended up tweaking the driver to add both startPositionChange and stopPositionChange methods. The added code is below that you may consider including in the driver. I also think "Switch Level" in the driver should be "SwitchLevel" although it still seems to work.

def stopPositionChange() {
stop()
}

def startPositionChange(direction) {
    direction == open ? open() : close()
}

Can you share you full groovy?

Also, the blind status is not showing up correctly using the @DevOpsTodd code; are you seeing anything like that? Below is an example from my Hubitat Dashboard, blind is closed (0%) but still shows 'on'.

This looks like a template issue. Make sure that they are shades and you set the shade open and closed colors accordingly. Don't set an on/off color. There's no on/off value to shades. It's open or closed or partially open.

Download the Hubitat app