Something change in 2.1.4 with "toggle" command for Button Controller?

I had a button controller configured to toggle a smart bulb, and for months it's worked great. Now, it doesn't toggle. It turns on, but never turns off. Previously, click once, it sets to 100%. Click and hold, it sets to 10%. Click again in either situation, it turns off. Now, click it if it's at 10%, it ramps up to 100%. Click again, nothing. Clink and hold, it dims to 10%.

It's like "toggle" is being treated as "on". These are Button Controller 1.6 rules, so maybe it just broke the old rules?

This probably isn't the same issue but check the event logs for your button I had a similar situation and when I looked the button was reporting 1 press sometimes and 2 presses others. I ended up using the press to turn on and hold to turn off.

This was with a SmartThings Button, although I had other ST buttons that were still working as they should so I figured it was something to do with that 1 device.

This is also a ST button. it worked great for months... maybe battery?

Possibly, although it is still working fine with the press/hold config rather than the toggle. The problem with the toggle was when it detected the button being pressed once it would turn on the light then the next time I pressed the button it would detect two presses and turn off then immediately turn the light on, it happened so fast I didn't notice any difference with the light.

We have a 2 year old grandson who loves grabbing any of our buttons he finds and turning the lights on/off/on/off... so the hold to turn off works well anyway as he looses interest in the button quickly when all it does is turn on :slight_smile:

button is only registering as a single push.

So something changed with Button Controller seemingly. =(

Button Controller 3.0 did not change in 2.1.4.

Please see if you can create the same rule in Rule 4.0. Rule 4.0 has Button Controller built in to it. When you first go to create a rule, select "Button Device" as the trigger capability, and that will bring up the Button Controller UI.

Even with respect to your existing BC rule, turn on logging and see what it's doing.

1 Like

This rule is an old BC 1.6 rule. It may have broken in 2.1.3, I'm not sure when it last worked.

I'll try in RM. Standby...

update Just created in BC 3.0, same result.
In RM, I can only figure out how to have one trigger event rather than a combined "push" and "hold" in same rule. But my RM-fu is weak. Toggle Dim also seems broken for RM4. It turns on, but pushing again does not toggle it off.

Here's log from RM. Pushed it a total of 3 times. First time turned bulb on. Second two times did nothing.

[app:483]( 05:51:28.036 pm [info]( Toggle Dim: Bulb - Sean’s Corner Light: 100

[app:483]( 05:51:28.011 pm [info]('s Corner Light Button Triggered

[app:483]( 05:51:27.999 pm [info]('s Corner Light Button: Button - Sean's Corner Light pushed 1

[app:483]( 05:51:25.049 pm [info]( Toggle Dim: Bulb - Sean’s Corner Light: 100

[app:483]( 05:51:25.022 pm [info]('s Corner Light Button Triggered

[app:483]( 05:51:25.009 pm [info]('s Corner Light Button: Button - Sean's Corner Light pushed 1

[app:483]( 05:51:22.415 pm [info]( Toggle Dim: Bulb - Sean’s Corner Light: 100

[app:483]( 05:51:22.385 pm [info]('s Corner Light Button Triggered

[app:483]( 05:51:22.371 pm [info]('s Corner Light Button: Button - Sean's Corner Light pushed 1

I just tested in 4.0 with a ST button and a Sengled bulb and it worked correctly.

One thing I did notice is you need a good 2-3 seconds between presses to re-trigger. Pressing again too fast is probably either registering as a double tap. or the dimming messages from the prior press haven't completed yet. I would suggest setting up a virtual button and seeing how that works.

The only thing changed in BC 1.6 was the retiring of SMS.

same result with virtual button. Sengled bulb as well. I did set the bulb to be the Sengled Element driver... maybe that's it?

Applying to see if maybe rebooting hub helps. Otherwise, not sure what's going on.

[app:483]( 08:13:02.608 pm [info]( Toggle Dim: Bulb - Sean’s Corner Light: 100

[app:483]( 08:13:02.572 pm [info]('s Corner Light Button Triggered

[app:483]( 08:13:02.541 pm [info]('s Corner Light Button: Button - Test pushed 1

[dev:898]( 08:13:02.393 pm [info]( - Test button 1 was pushed

Mine are still Generic Zigbee Bulb. Let me change one and test again.

Yup. that was it. Setting the Sengled bulb to the "Sengled Element Classic" (which is what it is) was the culprit. Resetting back to Generic Zigbee Bulb fixed it.

1 Like

I'm glad you got it working. Interestingly, I switched the bulb to the Sengled Element Classic driver and it still worked. Weird!

Did you remember to click CONFIGURE after changing the driver?

I did not. I honestly did not believe configure ever did anything. If it’s significant why not auto-trigger the configure when the driver is changed?

Will try again with a configure.

1 Like

Configure seems to have fixed it. Damn.

Still wonder why we wouldn’t auto-trigger a configure when changing the driver and clicking save.

1 Like

Sometimes you need to use a driver that may allow you to configure a device differently than the stock driver will allow, but then you need to change back to the stock driver without it undoing the changes you made.

1 Like

guess that makes some sense. Still think it should be more "obvious" that a configure should be required. Maybe a checkbox next to "Save" that defaults to checked when the driver is changed.

1 Like