Someone help, going nuts. everything just stopped working or very slow

someone please help. i am super frusterated. all worked good, i have spent multiple hours seting things up. was working great until its not. no or slow response. i have soft reset things, i have done a backup from 5 months ago when things worked great. nothing works. it just slow or no response. i am about ready to move from hubitat.

i have read through threads and threads on here with people with the same issue and i cant find a good answer.

maybe someone can tell me how to find ghost devices? wouldnt those go away if i did a backup from five months ago when i had issues?

there is no number to call with issues so i hope i get help here.

This is a good starting point:

No, unless you did a Z-wave radio reset AND had a cloud backup from Hub Protect (only way to restore the ZWave radio).

Typically this would be Z-Wave, anything on the Z-Wave details with no device name listed on the right side. -- How To: Remove Z-Wave Ghosts (including using a UZB Stick) (Also tips how to remove without a USB stick)


That isn't much to go off of. Slow when you use a dashboard? Slow automations? Slow when you operate the device from the settings page? Zigbee, Zwave, or Wifi devices? C5, C7, C8 hub? Hub firmware version? Has it always done this, or is this new behavior? How long have you owned the hub?

It would help us if you could give as much information as you can from in the linked post above.


@user6819 We need a bit more info. What exactly is the issue? What model hub etc? You're not giving us much to go on.


I totally get it that after spending countless of hours over a certain period of time, setting up devices and rules, just the way you like it, when things go wrong it could be very frustrating. I know that because I've been in your shoes many times, on different platforms.

A smart home delivers convenience but it requires some minimal maintenance and care on a regular basis. The frequency between the routine maintenance depends on how often changes occur in one's environment.

When you first build the smart home you create links between connected devices that can break without user even making any changes. Moreover, adding new devices into the mix increases the risk of breaking those links. Every time a link breaks, it could lead to unintended consequences across the entire smart home environment.

When things do break, it is imperative to narrow down the root cause by starting with the misbehaving app and tracking down the devices involved. Identifying if it's one device, multiple devices or all devices within one protocol is critical. Often times, one single device can go bad and could cause many links to break.

This may seem burdensome, but is really not. I am rarely facing problems with my own smart home, but when I do run into problems, I follow these steps:

  1. if I recently updated the hub and odd things started to happen, I go to the Diagnostic Tool and immediately restore the previously running version.
  2. if an app is misbehaving, I track down the devices that the app is using and manually check if they work from Device Details page.
  3. If more than one device is not working, I check to make sure that Zigbee Radio and Z-Wave Radio are working. Having at least one functional device for each radio is indicative that the radio is functional.
  4. If the radio are functional, then I power cycle each misbehaving device, then check again if they started working again.
  5. For devices that no longer work even after a power cycle, depending on the time I want to spend, I may remove them and re-add them. Or if it's not the first time they are misbehaving, I just replace them with another device. The time I spend on maintaining my smart home is very limited, so more often than not I just remove and replace the device with a new one. It takes less time doing so than trying to make something work that really doesn't.

For more ideas on troubleshooting apps and devices you may want to check out this document: How to Troubleshoot Apps or Devices | Hubitat Documentation


okay, i bought a Zooz zwave stick and deleted ghost devices. things worked good for a few days and now again everthing is slow and or non responsive. all ghost devices have been removed.


You've provided no additional information - w/out additional info we just cannot help you. See @jtp10181's post above.

You wouldn't call a mechanic and say "My car is running rough." and expect him to know what's wrong and provide a fix from so little info. If you aren't willing to take the time to help us help you, we're both going to end up frustrated.


logs show the following:

i dont know what it means though.....

i dont know what other information provide.... please help me know what information to provide.

everthing worked fine until one day did not. i deleted ghost devices and worked okay for a few days, then issues again.

i tried resetting the hub. no dice. still does not work, devices stopped responding.

Thats just debug logs, you can click where it says "debug" in blue to open that device and turn the debug logging off.

Did you read my pinned post? You have not even said what hub model you have that I see.

Post a screenshot of the entire z-wave details page.

We did already, its listed in here:


C7, i will screenshot

A couple people have asked you questions, here is mine from above...

So far we know it is a C7.

Anything else you can add?

Yeah we need to know what is slow exactly? Is it Z-wave devices? Which devices are the most problematic?

I see a few z-wave devices that may be struggling.
Would be good to see the z-wave details again after the hub has been running for at least 12 hours, this looks like it was fresh after a reboot.

What hub Firmware do you have installed?

Make sure you do not have a Z-Wave firmware update available: C7 2.3.1 and Z-Wave Firmware 7.17.1
That post is older, the current version is 7.18, but directions are the same.

You could be running into a memory problem from 2.3.6, follow these steps to resolve that potential issue: Hub is running low on memory C-7 - #3 by jtp10181

  1. Create and download a backup
  2. Update the hub to 2.3.7
  3. Reboot and check the rebuild database option on the confirmation dialog
1 Like

hi, thanks. so i have owned the c7 for a couple years. i rebuilt it about six months ago. i have used abode for most automations and had hubitat for others. i switched to all hubitat about six months ago when abode automations broke.

i now have hubitat hooked up to home assistant and abode hooked up to home assistant (indirectly working with hubitat).

Everything is running through hubitat basically. Had no issues for six months. all of the sudden a few weeks ago started having issues.

very slow response. i have about a 1 minute delay in response on everything. sometimes they firs no issue once or twice and then delay starts.

noticed i had some ghose devices on zwave so i got a zooz stick and erased ghost devices. did a soft reset. most things seemed to work solid for a day or two then the delay kicked in again. same issue. super slow if any response at all. it seems like if i run a automation the hubitat self destructs. again, no new recent automations.

i have some zigbee stair lights that run through hue and activated by zwave motion. i feel like that automation runs without issue but all else have issues. like i said 1 mintute delay. it seems maybe zibee is woking better than zwave.

my wife is going nuts all she wanta is the dog lights to come on when she opens doors for dogs. works for a day or two and then unreliable.

how do i determine zwave firmware. Hubitatat says software is up to date.

If you're talking about the (C7) hub's own z-wave radio update, the instructions are linked in Jeff's post right above your last post here. When/if available, it is handled outside/independently of the hub's overall firmware updates.

Individual ZW device firmware is made available by the respective manufacturer and must be manually applied.

no he had a question about the hub zwave software.

basically, if i run anything that is run through an app it bogs the system down. if i update a device through dashboard, if i have not ran anything in a few minutes then it fires right up a few times and then starts slowing down. basically, right when i think thank goodness it is working again, it just stops and takes minutes to respond. overall, the system is basically unreliable.

i will see if i can follow the zwave running low on memory steps.