[Solved] Upgrading to firmware 2.2.5.131 & 2.2.6.140 breaks my Thermostat Controllers

Hello! I've got two thermostat controllers running on my hub and working fine on 2.2.4.158. I tried upgrading twice now to 2.2.5.131 and each time I had to roll back and reload my configuration from 2.2.4. I had tried upgrading to one of the earlier 2.2.5 releases as well and was getting a null pointer exception so I'm wondering if my 2.2.4 configuration for my thermostat controller is somehow incompatible with 2.2.5? Let me know if there's an easy way to share that. Here's one of the controllers settings from the App UI:

Note the cooling set point is really high because 2.2.4 doesn't support "heat only" thermostat controllers and both of my thermostat controllers are for heat only. My cooling is on a separate thermostat I haven't upgraded yet.

I tried upgrading to 2.2.6.140 as well, and I'm still seeing issues.
@bravenel sorry to ping directly. I even tried deleting my controllers and reinstalling them, to no avail. It seems like when it's pulling in the basic settings from my centralite pearls, it's not getting the heating modes?

Show the device page for Family Room Thermostat. What driver does it use?

It's generic zigbee. I looked to see if there was a specific driver for the Centralite Pearl but didn't see anything in the drop down.

I need to see the top part of the page.

Sorry about that. Here we are.

Something I also noticed - the fan mode on 2.2.4 is "auto" whereas the fan mode in 2.2.6 is "unknown" - unsure if that helps at all?

Your thermostat is not configured correctly. It's not showing any modes. See this one:

You might try hitting Configure for it. Not sure, but it may help if you reset it, and re-pair it with the hub (don't remove the device).

Oh interesting. Do you suggest I do this on 2.2.4 or 2.2.6?

I'd try it on 2.2.6, in case there were some bug fixes relative to 2.2.4.

That seems to look better. Just pressed configure, which I'm 99% sure I pressed on 2.2.4 as well so your thoughts on bugs related to that in 2.2.4 seem spot on. Going to try the controllers again and see how that goes.

Yep that was it. Now this populated correctly, and when I went to change the temperature the furnace kicked on correctly.

Thanks so much @bravenel - will mark the misconfiguration post as the solution.

2 Likes

Download the Hubitat app