[Solved] Seeing "wifiDisconnect" events and reboots on C7 daily

I'm seeing daily occurrences of wifiDisconnect events, with subsequent reboots of my C7 hub:

Not sure if this started after the upgrade to 2.3.1 (running 2.3.1.134 now).
I haven't noticed any wifi problems in my house - and I work remotely the whole day from my laptop. The hub is close to the router, and it runs hub mesh with a C4 (wired).
C7 is using TP-Link TL-WN823N N300 Mini USB.

Anyone else seeing this?

Should probably talk with @gopher.ny on this, but check your Network Setup and see if you have DHCP auto reconnect turned on. It’s not the cause of the disconnects but it may be what is asking the hub to reboot after detecting the drops.

1 Like

It wasn't enabled - I did enable it. Let's see if that changes anything.
Thanks!

We are aware that some users experience frequent disconnects when using Wi-Fi adapters. The option is still in beta. We recommend the adapters to be used as a temporary solution, not as a replacement of hard wired Ethernet connection to the router.

1 Like

Having run a main home hub on WiFi for over a year, I'd say reboot the router and power cycle the WiFi adapter (shut down the hub, unplug USB cable from the power adapter for 15-20 seconds, plug it back in).

And yes, WiFi connectivity with external USB adapters is not as stable as we hoped for. What you see is a band-aid to keep the hub from going offline for extended time. I see it happening on my home hub as well, although not daily.

4 Likes

I’m guessing that it may be more prevelant with routers that don’t have a separate 2.4GHz SSID. Question on this though, if Iwere to happen to have a dual band wifi adapter do we think that the drivers would work with it?

2 Likes

The option is still in beta. We recommend the adapters to be used as a temporary solution, not as a replacement of hard wired Ethernet connection to the router.

Understood; not complaining, just noticing and reporting.
Wiring the C7 is not an option right now, but I'll keep it in mind for the future.

1 Like

The adapter I use is TP-Link AC600, a dual band one. My home network had the same name for 2.4GHz and 5GHz bands. I'm going to rename the 2.4GHz and see how it affects stability going forward, although it will take a couple of weeks to get meaningful observation results.

6 Likes

I believe I figured a better way to monitor WiFi disconnects. Updated logic should be out soon, I'll make sure it is in the release notes when it's out. Also, connecting to a dedicated 2.4GHz network with a separate SSID doesn't seem to make a difference.

3 Likes

That sounds like good news.
Just to add to the observations here, a couple of days ago I switched the DNS setting in my C7 from the default (Google's 8.8.8.8) to my own router. I guess it's purely accidental, but the C7 hasn't rebooted since (48 hours now). I'll report back if/when the next reboot hits - which may happen immediately after I click "Reply" here...

1 Like

...of course a few hours after the post above, the C7 hub did restart due to lost wifi connectivity...

Check out update 2.3.1.137, it has the WiFi disconnect/reconnect change mentioned a couple of posts above.

1 Like

Upgrading now; I'll report back in a few days.

1 Like

@gopher.ny good news so far: no C7 (wifi) restarts in the last 72 hours!

3 Likes

I'm marking this as resolved, as, since switching to @gopher.ny 's change in 137, I haven't seen a single restart.

3 Likes

Download the Hubitat app