[Solved] Lutron RA2 Select UK Pico help C8 Pro

Hi, I have a Lutron RA2 Select in the UK. I have used the Lutron app to connect all my dimmers and Pico remotes. All work using the Lutron app.

I have connected all my devices onto the C8 Pro using the Lutron integrator app. I can see all my devices on the devices screen.

As a test I have created a rule for one of my Pico remotes. However, the system does not recognise the remote button being pressed and the Lutron app seems to be the one directing what the remote functions are. Not the Hubitat settings.

How can I rectify this so that the Hubitat rule works please?

Thanks in advance!

Remove the binding of the pico in the lutron app.

What does your integration page look like?

It should look like the example below. Open a live log while pressing the pico. Set a static ip on the lutron hub and put that ip in the lutron integration.

Put all the Picos you want to use via Hubitat in a room by themselves in the Lutron app.


This worked a treat! Thank you :slight_smile:

1 Like