[Solved] Lock rule not working?


#1

I have a super simple rule:

The logs show it ran my action:
Action: Lock: Front Door Lock, Kitchen Door Lock

But the lock doesn't lock. If I go to my Kitchen Door Lock device and click the lock button it locks though. Any idea why it says it's locking but the lock doesn't lock? The rule is so simple it can't be wrong... The lock is a virtual lock, not sure if that matters


#2

Solved my own problem, the virtual locks don't like when I send commands to 2 locks too quickly...


#3

Can you lock and unlock the lock from the edit device page? What type of locks are these? If they are z-wave, z-wave locks are incredibly finicky. Some of them have to have a "beaming repeater" in close proximity.

See, z-wave locks don't keep a constant connection to the hub like mains powered devices do. They wake up frequently to check to see if they have a command to unlock. A "beaming repeater" being nearby will repeat the same command over and over again to the lock so that it is received when it wakes up. Without a beaming repeater to get the signal from, the lock will lose most commands sent to it. But again, this is only true for z-wave locks.