[Solved] Hue bridge cannot be found

I just got my Hubitat, and am trying to connect it to my Hue Bridge. I installed the Hue Bridge Integration App, opened it up, and gotten to the screen where it says it's searching for my Hue Bridge, and I need to be patient. I've let it sit there until it times out multiple times, and it always fails to find the bridge. I've uninstalled and reinstalled the Integration app, as well as rebooted the hubitat hub. Is there some trick I'm just missing?



You are pushing the button on the Hue hub correct?

I think I'm at the step before that. The instructions make it sound like the first step is you just wait until it finds your hub. Then, you press the button. I'm not even getting through the first step. The Hue Hub is on (and on the same network). I can open up the Hue app and control things as expected. The Hubitat just refuses to see it.

Try a reboot of the Hubitat Hub

I've tried rebooting the Hubitat Hub, the Hue Hub, and pushing the button on the Hue Hub during the first discovery attempt. Unfortunately, no luck, yet. Thanks for the ideas, though!


I know these are long shots, but I thought I'd give a couple ideas at least.

Is the hue hub firmware up to date?

And I've seen some people complaining in threads that if they have a google wifi system, devices aren't seeing each other correctly. I don't have google wifi, so I only skim those posts - but if that relates to you maybe check if that is the issue.

The firmware is up to date. And, I finally figured out my problem. I tried to add my Sonos equipment, and got the same behavior - a hang at the discovery phase, and never any success. That got me really suspicious. The problem was in my network topology.

I have a Google Fiber box, with an ethernet switch plugged into it. Everything else is either connected to that switch, or connected to a Netgear Orbi wireless network, which is also ultimately connected to that switch. All IP address assigning is handled by the Google Fiber box (the Orbi is running in bridge mode). I considered this all to be one network, but the Hubitat Hub didn't like being connected through an ethernet port on the satellite Orbi. Once I moved it directly to the main switch, it worked just fine.